]> code.ossystems Code Review - openembedded-core.git/commitdiff
libcap: update 2.44 -> 2.45
authorAlexander Kanavin <alex.kanavin@gmail.com>
Fri, 4 Dec 2020 20:07:17 +0000 (21:07 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 9 Dec 2020 12:15:17 +0000 (12:15 +0000)
Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-support/libcap/files/0001-tests-do-not-statically-link-a-test.patch
meta/recipes-support/libcap/files/0002-tests-do-not-run-target-executables.patch
meta/recipes-support/libcap/libcap_2.45.bb [moved from meta/recipes-support/libcap/libcap_2.44.bb with 96% similarity]

index d9fd48a9db5c81b30c096d02c8ba9fc5c9ee4ba6..3c737b884eb954be676bb68e98e1bdc08d12a6bf 100644 (file)
@@ -1,4 +1,4 @@
-From 03e925f0d68bc51e1acf1ac2014a9c2452c664bf Mon Sep 17 00:00:00 2001
+From c22c6c16362c7dbc8d6faea06edee5e07759c5fa Mon Sep 17 00:00:00 2001
 From: Alexander Kanavin <alex.kanavin@gmail.com>
 Date: Wed, 15 Jan 2020 17:16:28 +0100
 Subject: [PATCH] tests: do not statically link a test
@@ -9,23 +9,37 @@ Upstream-Status: Inappropriate [oe-core specific]
 Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com>
 
 ---
+ progs/Makefile | 2 +-
  tests/Makefile | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
2 files changed, 3 insertions(+), 3 deletions(-)
 
+diff --git a/progs/Makefile b/progs/Makefile
+index 1d7fc7a..37db8f7 100644
+--- a/progs/Makefile
++++ b/progs/Makefile
+@@ -42,7 +42,7 @@ endif
+ test: $(PROGS)
+ tcapsh-static: capsh.c $(DEPS)
+-      $(CC) $(IPATH) $(CAPSH_SHELL) $(CFLAGS) -o $@ $< $(LIBCAPLIB) $(LDFLAGS) --static
++      $(CC) $(IPATH) $(CAPSH_SHELL) $(CFLAGS) -o $@ $< $(LIBCAPLIB) $(LDFLAGS)
+ sudotest: test tcapsh-static
+       sudo $(LDPATH) ./quicktest.sh
 diff --git a/tests/Makefile b/tests/Makefile
-index d569650..f5ca377 100644
+index 3431df9..727fb86 100644
 --- a/tests/Makefile
 +++ b/tests/Makefile
-@@ -11,7 +11,7 @@ ifeq ($(DYNAMIC),yes)
- LDPATH = LD_LIBRARY_PATH=../libcap
- DEPSBUILD = all
+@@ -22,7 +22,7 @@ ifeq ($(PTHREADS),yes)
+ DEPS += ../libcap/libpsx.so
+ endif
  else
 -LDFLAGS += --static
-+LDFLAGS += 
- DEPSBUILD = libcap.a libpsx.a
- endif
-@@ -51,7 +51,7 @@ libcap_psx_launch_test: libcap_launch_test.c $(DEPS)
++LDFLAGS +=
+ DEPS=../libcap/libcap.a ../progs/tcapsh-static
+ ifeq ($(PTHREADS),yes)
+ DEPS +=  ../libcap/libpsx.a
+@@ -106,7 +106,7 @@ noexploit: exploit.o $(DEPS)
  
  # This one runs in a chroot with no shared library files.
  noop: noop.c
index bfce8e05477fc34be35702141dbc061f93fdafcd..69287152eb29ccc74d5e590f05418a1d8031c97f 100644 (file)
@@ -1,4 +1,4 @@
-From 7744c1f678f5226a151bc6b2a254a56835229d91 Mon Sep 17 00:00:00 2001
+From 652071e430d5eea758965176b7648e79ad404daa Mon Sep 17 00:00:00 2001
 From: Alexander Kanavin <alex.kanavin@gmail.com>
 Date: Fri, 20 Dec 2019 16:54:05 +0100
 Subject: [PATCH] tests: do not run target executables
@@ -11,20 +11,20 @@ Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com>
  1 file changed, 2 deletions(-)
 
 diff --git a/tests/Makefile b/tests/Makefile
-index 8956d5d..d569650 100644
+index fc39fee..3431df9 100644
 --- a/tests/Makefile
 +++ b/tests/Makefile
-@@ -27,13 +27,11 @@ sudotest: test run_libcap_launch_test run_libcap_launch_test
- install: all
+@@ -59,13 +59,11 @@ endif
  
+ # unprivileged
  run_psx_test: psx_test
--      $(LDPATH) ./psx_test
+-      ./psx_test
  
  psx_test: psx_test.c $(DEPS)
-       $(CC) $(CFLAGS) $(IPATH) $< -o $@ $(LIBPSXLIB)
+       $(CC) $(CFLAGS) $(IPATH) $< -o $@ $(LINKEXTRA) $(LIBPSXLIB) $(LDFLAGS)
  
  run_libcap_psx_test: libcap_psx_test
--      $(LDPATH) ./libcap_psx_test
+-      ./libcap_psx_test
  
  libcap_psx_test: libcap_psx_test.c $(DEPS)
-       $(CC) $(CFLAGS) $(IPATH) $< -o $@ $(LIBCAPLIB) $(LIBPSXLIB) $(LDFLAGS)
+       $(CC) $(CFLAGS) $(IPATH) $< -o $@ $(LINKEXTRA) $(LIBCAPLIB) $(LIBPSXLIB) $(LDFLAGS)
similarity index 96%
rename from meta/recipes-support/libcap/libcap_2.44.bb
rename to meta/recipes-support/libcap/libcap_2.45.bb
index 79875522d667158af7d4e50524dbeb4c9ad05d06..067ba32d99951fe32617c3135a2453bb86287145 100644 (file)
@@ -12,7 +12,7 @@ SRC_URI = "${KERNELORG_MIRROR}/linux/libs/security/linux-privs/${BPN}2/${BPN}-${
            file://0002-tests-do-not-run-target-executables.patch \
            file://0001-tests-do-not-statically-link-a-test.patch \
            "
-SRC_URI[sha256sum] = "92188359cd5be86e8e5bd3f6483ac6ce582264f912398937ef763def2205c8e1"
+SRC_URI[sha256sum] = "d66639f765c0e10557666b00f519caf0bd07a95f867dddaee131cd284fac3286"
 
 UPSTREAM_CHECK_URI = "https://www.kernel.org/pub/linux/libs/security/linux-privs/${BPN}2/"