]> code.ossystems Code Review - openembedded-core.git/commitdiff
libnl: Fix compile header problems
authorRichard Purdie <rpurdie@linux.intel.com>
Fri, 4 Sep 2009 09:37:13 +0000 (10:37 +0100)
committerRichard Purdie <rpurdie@linux.intel.com>
Fri, 4 Sep 2009 09:37:13 +0000 (10:37 +0100)
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
meta/packages/libnl/libnl/compilefix.patch [new file with mode: 0644]
meta/packages/libnl/libnl/local-includes.patch [moved from meta/packages/libnl/files/local-includes.patch with 100% similarity]
meta/packages/libnl/libnl_1.1.bb

diff --git a/meta/packages/libnl/libnl/compilefix.patch b/meta/packages/libnl/libnl/compilefix.patch
new file mode 100644 (file)
index 0000000..f75ff28
--- /dev/null
@@ -0,0 +1,12 @@
+Index: libnl-1.1/include/netlink-local.h
+===================================================================
+--- libnl-1.1.orig/include/netlink-local.h     2009-09-04 10:10:09.000000000 +0100
++++ libnl-1.1/include/netlink-local.h  2009-09-04 10:10:15.000000000 +0100
+@@ -26,6 +26,7 @@
+ #include <sys/socket.h>
+ #include <inttypes.h>
+ #include <assert.h>
++#include <limits.h>
+ #include <arpa/inet.h>
+ #include <netdb.h>
index 97ac25f73375017c6f9bb788656cc7265e7ea956..05c0e32bb2dc6480d0345e75362f16ce048c0c23 100644 (file)
@@ -3,11 +3,11 @@ SECTION = "libs/network"
 LICENSE = "LGPL"
 HOMEPAGE = "http://people.suug.ch/~tgr/libnl/"
 PRIORITY = "optional"
-PV = "1.1"
 
 inherit autotools_stage pkgconfig
 
-SRC_URI= "http://people.suug.ch/~tgr/libnl/files/${PN}-1.1.tar.gz \
-           file://local-includes.patch;patch=1"
+PR = "r1"
 
-S = "${WORKDIR}/${PN}-1.1"
+SRC_URI= "http://people.suug.ch/~tgr/libnl/files/${PN}-${PV}.tar.gz \
+          file://local-includes.patch;patch=1 \
+          file://compilefix.patch;patch=1"