]> code.ossystems Code Review - openembedded-core.git/commitdiff
buildtools-tarball: Add wget to buildtools-tarball
authorTudor Florea <tudor.florea@enea.com>
Sun, 20 Jul 2014 20:00:43 +0000 (22:00 +0200)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 21 Jul 2014 18:03:52 +0000 (19:03 +0100)
GNU Wget cannot be upgrated to a newer that 1.12 version on supported
Centos distro. GNU Wget 1.12 and earlier uses a server-provided filename
instead of the original URL to determine the destination filename of a
download.
This means the files downloaded when fetching cannot be properly used:
$ wget http://www.balabit.com/downloads/files/syslog-ng/open-source-edition/3.4.2/source/eventlog_0.2.13.tar.gz
$ ls
eventlog_0.2.13.tar.gz?AWSAccessKeyId=AKIAICTJ5MANGPMOH7JA&Expires=1400838672&Signature=TjakOBpOvHtEKKDgF14iVinWpY0=
This in turn lead to build errors like:
WARNING: Failed to fetch URL http://www.balabit.com/downloads/files/syslog-ng/open-source-edition/3.4.2/source/eventlog_0.2.13.tar.gz, attempting MIRRORS if available
ERROR: Fetcher failure for URL: 'http://www.balabit.com/downloads/files/syslog-ng/open-source-edition/3.4.2/source/eventlog_0.2.13.tar.gz&#39;. The fetch command returned success for url http://www.balabit.com/downloads/files/syslog-ng/open-source-edition/3.4.2/source/eventlog_0.2.13.tar.gz but /path/to/downloads/eventlog_0.2.13.tar.gz doesn't exist?!
ERROR: Function failed: Fetcher failure for URL: 'http://www.balabit.com/downloads/files/syslog-ng/open-source-edition/3.4.2/source/eventlog_0.2.13.tar.gz&#39;. Unable to fetch URL from any source.
ERROR: Logfile of failure stored in: /path/to/tmp/work/ppce500v2-enea-linux-gnuspe/eventlog/0.2.13-r0/temp/log.do_fetch.28302
ERROR: Task 4 (/path/to/poky/meta-openembedded/meta-oe/recipes-support/eventlog/eventlog_0.2.13.bb, do_fetch) failed with exit code '1'

[YOCTO #6549]

Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-core/meta/buildtools-tarball.bb
meta/recipes-extended/wget/wget.inc
meta/recipes-support/gnutls/gnutls.inc
meta/recipes-support/nettle/nettle_2.7.1.bb

index 62e1e0bbef342525f1e581aaa3db72a873619602..c54d9e869953e159bb5b1bb4ae58bf0350f83e57 100644 (file)
@@ -41,6 +41,7 @@ TOOLCHAIN_HOST_TASK ?= "\
     nativesdk-git \
     nativesdk-pigz \
     nativesdk-make \
+    nativesdk-wget \
     "
 
 TOOLCHAIN_OUTPUTNAME ?= "${SDK_NAME}-buildtools-nativesdk-standalone-${DISTRO_VERSION}"
index 642d502a50709f8bcd32ae035c6f23af2126818a..a8ceb0e7458b5bc0dd2ad6e63f63bb84f799da8b 100644 (file)
@@ -4,6 +4,7 @@ SECTION = "console/network"
 LICENSE = "GPLv3"
 LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
 DEPENDS = "gnutls zlib libpcre"
+DEPENDS_class-nativesdk = "nativesdk-gnutls nativesdk-zlib nativesdk-libpcre"
 
 INC_PR = "r16"
 
@@ -13,6 +14,9 @@ EXTRA_OECONF = "--enable-ipv6 --with-ssl=gnutls --disable-rpath --disable-iri \
                 ac_cv_header_uuid_uuid_h=no"
 
 ALTERNATIVE_${PN} = "wget"
+ALTERNATIVE_${PN}_class-nativesdk = ""
 ALTERNATIVE_PRIORITY = "100"
 
 RRECOMMENDS_${PN} += "ca-certificates"
+
+BBCLASSEXTEND += "nativesdk"
index d89b764aaeb39abc6a5ff2cb1c5b1bca4fe50863..27aba26943575b500a1da649fc2052f1f4d79c11 100644 (file)
@@ -43,4 +43,4 @@ FILES_${PN}-xx = "${libdir}/libgnutlsxx.so.*"
 
 LDFLAGS_append_libc-uclibc += " -pthread"
 
-BBCLASSEXTEND = "native"
+BBCLASSEXTEND = "native nativesdk"
index 8aa535189666d0b7c1152dcd088e00680e6e7fa7..f53afcc5d45b4c52f1b1f71b2750a1d9920f2446 100644 (file)
@@ -23,4 +23,4 @@ do_configure_prepend() {
 
 inherit autotools
 
-BBCLASSEXTEND = "native"
+BBCLASSEXTEND = "native nativesdk"