]> code.ossystems Code Review - openembedded-core.git/commitdiff
Update udev from upstream oe (still using 092, just a newer PR, so the .debug stuff...
authorChris Larson <kergoth@openedhand.com>
Thu, 5 Oct 2006 21:56:07 +0000 (21:56 +0000)
committerChris Larson <kergoth@openedhand.com>
Thu, 5 Oct 2006 21:56:07 +0000 (21:56 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@788 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/udev/files/50-hostap_cs.rules [new file with mode: 0644]
meta/packages/udev/udev-092/local.rules
meta/packages/udev/udev-092/udev.rules
meta/packages/udev/udev.inc
meta/packages/udev/udev_092.bb

diff --git a/meta/packages/udev/files/50-hostap_cs.rules b/meta/packages/udev/files/50-hostap_cs.rules
new file mode 100644 (file)
index 0000000..efefdc5
--- /dev/null
@@ -0,0 +1,4 @@
+# hostap_cs needs ignore_cis_vcc=1 set - this should handle all cards
+#
+ACTION=="add", DEVICE=="hostap_cs", \
+ SYSFS{func_id}=="0x06", RUN+="/sbin/modprobe hostap_cs ignore_cis_vcc=1"
index d053334652fc988d9bf5c25b1a3a74609db79751..2308b52c4a1235e98f070425da1deb7465b64401 100644 (file)
@@ -28,4 +28,4 @@ KERNEL=="rtc0", SYMLINK+="rtc"
 ACTION=="add", DEVPATH=="/devices/*", ENV{MODALIAS}=="?*", RUN+="/sbin/modprobe $env{MODALIAS}"
 
 # Create a symlink to any touchscreen input device
-SUBSYSTEM=="input", KERNEL=="event[0-9]*", SYSFS{modalias}=="input:*-e0,1*,3,*k*a0,1,*18,*", SYMLINK+="input/touchscreen0"
\ No newline at end of file
+SUBSYSTEM=="input", KERNEL=="event[0-9]*", SYSFS{modalias}=="input:*-e0,1*,3,*a0,1,*18,*", SYMLINK+="input/touchscreen0"
index 9c4ea4214d3778cd86d94e8d437b7dc6df88ca40..c1834a9a1c3bda2f15d9bbec9f25ddb55fabd548 100644 (file)
@@ -96,3 +96,7 @@ KERNEL=="rfcomm[0-9]*", NAME="%k", GROUP="users", MODE="0660"
 
 # Firmware Helper
 ACTION=="add", SUBSYSTEM=="firmware", RUN+="/lib/udev/firmware_helper"
+
+# Samsung UARTS
+KERNEL=="s3c2410_serial[0-9]"   NAME="ttySAC%n"
+
index a3896a6978c0851d0fa15b67b00da1e54d9f9833..5245d6e2b31b5183b00700f6f33d9814b2a05201 100644 (file)
@@ -1,4 +1,4 @@
-DESCRIPTION = "udev is a program which dynamically creates and removes device nodes from \
+DESCRIPTION ?= "udev is a program which dynamically creates and removes device nodes from \
 /dev/. It responds to /sbin/hotplug device events and requires a 2.6 kernel."
 LICENSE = "GPL"
 
@@ -33,7 +33,8 @@ bindir = "/bin"
 sbindir = "/sbin"
 
 UDEV_EXTRAS = "<override me>"
-FILES_${PN} += "${usrbindir} ${usrsbindir}"
+FILES_${PN} += "${usrbindir}/* ${usrsbindir}/*"
+FILES_${PN}-dbg += "${usrbindir}/.debug ${usrsbindir}/.debug"
 EXTRA_OEMAKE = "-e \
                'EXTRAS=${UDEV_EXTRAS}' \
                'STRIP=echo'"
index 794a5257541166fbfe0fb5d8b52f75534ca6442a..87febedf058bb44e17b738233b07dcab85d4e357 100644 (file)
@@ -3,21 +3,26 @@ DESCRIPTION = "udev is a daemon which dynamically creates and removes device nod
 the hotplug package and requires a kernel not older than 2.6.12."
 RPROVIDES = "hotplug"
 
-PR = "r7"
+PR = "r11"
 
 SRC_URI = "http://kernel.org/pub/linux/utils/kernel/hotplug/udev-${PV}.tar.gz \
           file://noasmlinkage.patch;patch=1 \
           file://flags.patch;patch=1 \
           file://udevsynthesize.patch;patch=1 \
-           file://arm_inotify_fix.patch;patch=1 \
           file://udevsynthesize.sh \
-          file://mount.blacklist"
+           file://arm_inotify_fix.patch;patch=1 \
+          file://mount.blacklist \
+          "
+
+SRC_URI_append_h2200 = " file://50-hostap_cs.rules "
+PACKAGE_ARCH_h2200 = "h2200"
 
 require udev.inc
 
 INITSCRIPT_PARAMS = "start 03 S ."
 
-FILES_${PN} += "${base_libdir}"
+FILES_${PN} += "${base_libdir}/udev/*"
+FILES_${PN}-dbg += "${base_libdir}/udev/.debug"
 UDEV_EXTRAS = "extras/firmware/ extras/scsi_id/ extras/volume_id/ extras/run_directory/"
 EXTRA_OEMAKE += "libudevdir=/lib/udev"
 
@@ -48,3 +53,7 @@ do_install () {
        install -m 0755 ${S}/udevsynthesize ${D}${base_libdir}/udev/udevsynthesize
        install -m 0755 ${WORKDIR}/udevsynthesize.sh ${D}${sbindir}/udevsynthesize
 }
+
+do_install_append_h2200() {
+       install -m 0644 ${WORKDIR}/50-hostap_cs.rules         ${D}${sysconfdir}/udev/rules.d/50-hostap_cs.rules
+}