]> code.ossystems Code Review - openembedded-core.git/commitdiff
perl: use ${CCLD} instead of its own LD definition
authorKevin Tian <kevin.tian@intel.com>
Wed, 5 Jan 2011 06:50:33 +0000 (14:50 +0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 7 Jan 2011 11:09:48 +0000 (11:09 +0000)
perl explicitly assigns LD to a bogus value:
    oe_runmake perl LD="${TARGET_SYS}-gcc"
which breaks sstate-based build when toolchain is not generated locally,
due to lacking of --sysroot option. Use ${CCLD} instead to make this
relocatable.

Signed-off-by: Kevin Tian <kevin.tian@intel.com>
meta/recipes-devtools/perl/perl_5.8.8.bb

index 8e2f0c0af727b6d6cee3ea35c300bdeefde66e4f..5cd4d4fe2fe6b50a4c2fc73c3ab8bc2eeae015c1 100644 (file)
@@ -11,7 +11,7 @@ PRIORITY = "optional"
 # We need gnugrep (for -I)
 DEPENDS = "virtual/db perl-native grep-native"
 DEPENDS += "gdbm"
-PR = "r21"
+PR = "r22"
 
 # Major part of version
 PVM = "5.8"
@@ -114,7 +114,7 @@ do_compile() {
             sed -i -e 's|/usr/include|${STAGING_INCDIR}|g' ext/Errno/Errno_pm.PL
         fi
         cd Cross
-        oe_runmake perl LD="${TARGET_SYS}-gcc"
+        oe_runmake perl LD="${CCLD}"
 }
 
 do_install() {