]> code.ossystems Code Review - openembedded-core.git/commitdiff
freetype: disable harfbuzz
authorRoss Burton <ross.burton@intel.com>
Wed, 14 May 2014 10:13:19 +0000 (11:13 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 15 May 2014 22:24:04 +0000 (23:24 +0100)
Freetype has an automatically detected dependency on Harfbuzz, which has a
dependency on Freetype.

To produce deterministic builds and avoid link failures when rebuilding freetype
with harfbuzz present add a PACKAGECONFIG for Harfbuzz and disable it by
default.

Signed-off-by: Ross Burton <ross.burton@intel.com>
Signed-off-by: Saul Wold <sgw@linux.intel.com>
meta/recipes-graphics/freetype/freetype_2.5.3.bb

index 7182c219439051efc396fd6cf7f37b847ab5e7bf..5d239e85fa98338312afaa48256188c32ae41187 100644 (file)
@@ -26,6 +26,8 @@ EXTRA_OECONF = "--without-zlib --without-bzip2 CC_BUILD='${BUILD_CC}'"
 
 PACKAGECONFIG ??= ""
 PACKAGECONFIG[pixmap] = "--with-png,--without-png,libpng"
+# This results in a circular dependency so enabling is non-trivial
+PACKAGECONFIG[harfbuzz] = "--with-harfbuzz,--without-harfbuzz,harfbuzz"
 
 do_configure() {
        cd builds/unix