]> code.ossystems Code Review - openembedded-core.git/commitdiff
meta-environment: Two critical fixes to unbreak toolchains
authorRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 29 Sep 2014 16:44:53 +0000 (17:44 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 29 Sep 2014 16:46:28 +0000 (17:46 +0100)
Firstly, when multilib builds were being used, the same output files
were used in each case, being overwritten each time due to the fact that
REAL_MULTIMACH_TARGET_SYS has been expanded. Instead of immediate
expansion, just use assignment. This overrides the problematic define
in toolchain-scripts.bbclass but allows the multilib code to work.

Secondly, the target sysroot was being defined incorrectly which
this patch fixes. This was breaking the toolchains.

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-core/meta/meta-environment.bb

index c6d3bb8d1c45a4433a20a06c23b9da7da2b2265c..bd90f9fd7cab95c75d35b1d2da21c4b66e74f34a 100644 (file)
@@ -6,14 +6,14 @@ PR = "r8"
 
 EXCLUDE_FROM_WORLD = "1"
 
-REAL_MULTIMACH_TARGET_SYS := "${TUNE_PKGARCH}${TARGET_VENDOR}-${TARGET_OS}"
+REAL_MULTIMACH_TARGET_SYS = "${TUNE_PKGARCH}${TARGET_VENDOR}-${TARGET_OS}"
 
 inherit toolchain-scripts
 TOOLCHAIN_NEED_CONFIGSITE_CACHE += "zlib"
 
 SDK_DIR = "${WORKDIR}/sdk"
 SDK_OUTPUT = "${SDK_DIR}/image"
-SDKTARGETSYSROOT = "${SDKPATH}/sysroots/${TARGET_SYS}"
+SDKTARGETSYSROOT = "${SDKPATH}/sysroots/${REAL_MULTIMACH_TARGET_SYS}"
 
 inherit cross-canadian