]> code.ossystems Code Review - openembedded-core.git/commitdiff
task-core-tools.bb: Exclude lttng-ust for x86_64/uclibc
authorKhem Raj <raj.khem@gmail.com>
Thu, 21 Jul 2011 06:10:13 +0000 (23:10 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 22 Jul 2011 10:48:50 +0000 (11:48 +0100)
Signed-off-by: Khem Raj <raj.khem@gmail.com>
meta/recipes-core/tasks/task-core-tools.bb

index eed4afb69ea8b37d1813a0b88dea5a54df43c310..b0eb7d46e6f75f39b7ca74c930e520ac26f98d4a 100644 (file)
@@ -58,6 +58,15 @@ RRECOMMENDS_task-core-tools-profile = "\
 SYSTEMTAP = "systemtap"
 SYSTEMTAP_libc-uclibc = ""
 
+# lttng-ust uses sched_getcpu() which is not there on uclibc
+# for some of the architectures it can be patched to call the
+# syscall directly but for x86_64 __NR_getcpu is a vsyscall
+# which means we can not use syscall() to call it. So we ignore
+# it for x86_64/uclibc
+
+LTTNGUST = "lttng-ust"
+LTTNGUST_libc-uclibc = ""
+
 #    exmap-console
 #    exmap-server
 
@@ -66,7 +75,7 @@ SYSTEMTAP_libc-uclibc = ""
 # (which is required by lttng-ust) may not build on other platforms, like
 # MIPS.
 RDEPENDS_task-core-tools-profile_append_qemux86 = " valgrind lttng-ust ${SYSTEMTAP}"
-RDEPENDS_task-core-tools-profile_append_qemux86-64 = " lttng-ust ${SYSTEMTAP}"
+RDEPENDS_task-core-tools-profile_append_qemux86-64 = " ${LTTNGUST} ${SYSTEMTAP}"
 RDEPENDS_task-core-tools-profile_append_qemuppc = " lttng-ust ${SYSTEMTAP}"
 RDEPENDS_task-core-tools-profile_append_qemuarm = " lttng-ust"