]> code.ossystems Code Review - openembedded-core.git/commitdiff
linux-yocto/3.4: move PREEMPT_NONE to beagleboard standard kernel only
authorBruce Ashfield <bruce.ashfield@windriver.com>
Thu, 29 Nov 2012 18:47:10 +0000 (18:47 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 3 Dec 2012 14:23:37 +0000 (14:23 +0000)
A recent report of the preempt-rt beagleboard kernel not enabling full
-rt preemption out of the box revealed that the existing fix for SD
boot issues (which were fixed by disabling preemption) was the root
cause for the options not being enabled.

Although the fix for the SD card detection issues is still valid, it
also doesn't make sense to apply it to a kernel type that only exists
to support enhanced preemption. Since many variants of the board boot
with preemption enabled, opening the possibility of a boot problem is
acceptable, given that it allows the -rt kernel to be used.

Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Signed-off-by: Saul Wold <sgw@linux.intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-kernel/linux/linux-yocto-rt_3.4.bb
meta/recipes-kernel/linux/linux-yocto-tiny_3.4.bb
meta/recipes-kernel/linux/linux-yocto_3.4.bb

index 76ee542628b600ffdd63dea1d0f1560cd566ca5d..e0800ff2f92911067fbaf80e4741b63f58c96049 100644 (file)
@@ -10,7 +10,7 @@ KMETA = "meta"
 
 SRCREV_machine ?= "2572b13999da8129c37eb2bf7e9a8fa68dc2a4bf"
 SRCREV_machine_qemuppc ?= "2004632314104d4f31bb1577e955da53796f517c"
-SRCREV_meta ?= "472aaf880c9176a40de98c97e14355fe77478598"
+SRCREV_meta ?= "4e5f2b43acfbdb924edbdf42a816e3e2b15203b3"
 
 PR = "${INC_PR}.0"
 PV = "${LINUX_VERSION}+git${SRCPV}"
index 50890a3ce08dfc988d6fafe8c814f670fb2c0928..ab214c8665910f394bf7f24dfabd115ce47d2a1c 100644 (file)
@@ -13,7 +13,7 @@ LINUX_VERSION ?= "3.4.18"
 KMETA = "meta"
 
 SRCREV_machine ?= "f1c2320544eaffd6ecc7fcb8b18f8a0ed4ba2e14"
-SRCREV_meta ?= "472aaf880c9176a40de98c97e14355fe77478598"
+SRCREV_meta ?= "4e5f2b43acfbdb924edbdf42a816e3e2b15203b3"
 
 PR = "${INC_PR}.0"
 PV = "${LINUX_VERSION}+git${SRCPV}"
index 647244a5f83a151e11e4c0c40a956ab720fbbe11..bb3c860bf3343add170ab89ab6dcb31ab5381d94 100644 (file)
@@ -9,7 +9,7 @@ SRCREV_machine_qemuppc ?= "ae8e2cd14e47bceb9c2bdcb927b3a0ea61f6c311"
 SRCREV_machine_qemux86 ?= "f1c2320544eaffd6ecc7fcb8b18f8a0ed4ba2e14"
 SRCREV_machine_qemux86-64 ?= "f1c2320544eaffd6ecc7fcb8b18f8a0ed4ba2e14"
 SRCREV_machine ?= "f1c2320544eaffd6ecc7fcb8b18f8a0ed4ba2e14"
-SRCREV_meta ?= "1c5980714d482f8ccb72909b40f3e1467a3fd590"
+SRCREV_meta ?= "4e5f2b43acfbdb924edbdf42a816e3e2b15203b3"
 
 SRC_URI = "git://git.yoctoproject.org/linux-yocto-3.4.git;protocol=git;nocheckout=1;branch=${KBRANCH},meta;name=machine,meta"