]> code.ossystems Code Review - openembedded-core.git/commitdiff
net-tools: update to 2.10
authorOleksandr Kravchuk <open.source@oleksandr-kravchuk.com>
Fri, 19 Feb 2021 22:12:20 +0000 (23:12 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 23 Feb 2021 22:31:25 +0000 (22:31 +0000)
Removed upstreamed patches.

Added new package configs.

Signed-off-by: Oleksandr Kravchuk <open.source@oleksandr-kravchuk.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-extended/net-tools/net-tools/Bug_443075-ifconfig.c-pointtopoint_spelling.patch [deleted file]
meta/recipes-extended/net-tools/net-tools/Bug_541172-netstat.c-exit-codes.patch [deleted file]
meta/recipes-extended/net-tools/net-tools_2.10.bb [moved from meta/recipes-extended/net-tools/net-tools_1.60-20181103.bb with 94% similarity]

diff --git a/meta/recipes-extended/net-tools/net-tools/Bug_443075-ifconfig.c-pointtopoint_spelling.patch b/meta/recipes-extended/net-tools/net-tools/Bug_443075-ifconfig.c-pointtopoint_spelling.patch
deleted file mode 100644 (file)
index 74d7466..0000000
+++ /dev/null
@@ -1,26 +0,0 @@
-Description: Accept "pointtopoint" as a synonym for "pointopoint"
-Bug-Debian: https://bugs.debian.org/443075
-Author: Justin Pryzby <pryzbyj@libra>
-
-Upstream-Status: Pending
-Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-
---- a/ifconfig.c
-+++ b/ifconfig.c
-@@ -644,14 +644,14 @@
-           spp++;
-           continue;
-       }
--      if (!strcmp(*spp, "-pointopoint")) {
-+      if (!strcmp(*spp, "-pointopoint") || !strcmp(*spp, "-pointtopoint")) {
-           goterr |= clr_flag(ifr.ifr_name, IFF_POINTOPOINT);
-           spp++;
-           if (test_flag(ifr.ifr_name, IFF_POINTOPOINT) > 0)
-               fprintf(stderr, _("Warning: Interface %s still in POINTOPOINT mode.\n"), ifr.ifr_name);
-           continue;
-       }
--      if (!strcmp(*spp, "pointopoint")) {
-+      if (!strcmp(*spp, "pointopoint") || !strcmp(*spp, "pointtopoint")) {
-           if (*(spp + 1) != NULL) {
-               spp++;
-               safe_strncpy(host, *spp, (sizeof host));
diff --git a/meta/recipes-extended/net-tools/net-tools/Bug_541172-netstat.c-exit-codes.patch b/meta/recipes-extended/net-tools/net-tools/Bug_541172-netstat.c-exit-codes.patch
deleted file mode 100644 (file)
index 782b94b..0000000
+++ /dev/null
@@ -1,22 +0,0 @@
-Description: Bug#541172: netstat.c exit codes
-
-Upstream-Status: Pending
-Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-
---- a/netstat.c
-+++ b/netstat.c
-@@ -2237,12 +2237,14 @@
-             parsesnmp(flag_raw, flag_tcp, flag_udp, flag_sctp);
- #else
-             ENOSUPP("netstat", "AF INET");
-+            exit(1);
- #endif
-         } else if(!strcmp(afname, "inet6")) {
- #if HAVE_AFINET6
-             parsesnmp6(flag_raw, flag_tcp, flag_udp);
- #else
-             ENOSUPP("netstat", "AF INET6");
-+            exit(1);
- #endif
-         } else {
-           printf(_("netstat: No statistics support for specified address family: %s\n"), afname);
similarity index 94%
rename from meta/recipes-extended/net-tools/net-tools_1.60-20181103.bb
rename to meta/recipes-extended/net-tools/net-tools_2.10.bb
index e163a6948a6dc39827fe85bb55ce9b94792f26d8..de4a71597146ce48b0efa7a8ef81cc94085fc1a9 100644 (file)
@@ -6,14 +6,11 @@ LICENSE = "GPLv2+"
 LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
                     file://ifconfig.c;beginline=11;endline=15;md5=d1ca372080ad5401e23ca0afc35cf9ba"
 
-PV = "1.60-20181103+git${SRCPV}"
-SRCREV = "0eebece8c964e3cfa8a018f42b2e7e751a7009a0"
+SRCREV = "80d7b95067f1f22fece9537dea6dff53081f4886"
 SRC_URI = "git://git.code.sf.net/p/net-tools/code;protocol=https \
     file://net-tools-config.h \
     file://net-tools-config.make \
     file://Add_missing_headers.patch \
-    file://Bug_443075-ifconfig.c-pointtopoint_spelling.patch \
-    file://Bug_541172-netstat.c-exit-codes.patch \
 "
 
 S = "${WORKDIR}/git"
@@ -28,6 +25,8 @@ PACKAGECONFIG[hostname] = ""
 PACKAGECONFIG[arp] = ""
 PACKAGECONFIG[serial] = ""
 PACKAGECONFIG[plip] = ""
+PACKAGECONFIG[slattach] = ""
+PACKAGECONFIG[plipconfig] = ""
 
 do_configure() {
        # net-tools has its own config mechanism requiring "make config"
@@ -119,4 +118,4 @@ ALTERNATIVE_${PN}-mii-tool = "mii-tool"
 ALTERNATIVE_TARGET[mii-tool] = "${base_sbindir}/mii-tool"
 ALTERNATIVE_LINK_NAME[mii-tool] = "${base_sbindir}/mii-tool"
 
-BBCLASSEXTEND = "native nativesdk"
\ No newline at end of file
+BBCLASSEXTEND = "native nativesdk"