]> code.ossystems Code Review - openembedded-core.git/commitdiff
Hack up the handler some more so it roughly works
authorMatthew Allum <mallum@openedhand.com>
Mon, 3 Oct 2005 18:13:53 +0000 (18:13 +0000)
committerMatthew Allum <mallum@openedhand.com>
Mon, 3 Oct 2005 18:13:53 +0000 (18:13 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky@108 311d38ba-8fff-0310-9ca6-ca027cbcb966

openembedded/packages/chkhinge26/chkhinge26_0.0.bb
openembedded/packages/chkhinge26/files/hinge-handler

index 4ea9ebab3ac292c9618cb2be49dedccbfb3764d1..adf1bf03137c390e32fb66322dd1716daa6081e8 100755 (executable)
@@ -14,5 +14,5 @@ do_install_append () {
        install -m 0755 ${WORKDIR}/hinge-handler ${D}/${bindir}/
 }
 
-FILES_${PN} += "${BINDIR}/hinge-handler"
+FILES_${PN} += "${bindir}/hinge-handler"
 
index 12d0172e422da83b1282b677bf7962b2d95c2717..d8100e9b2e4018b4a0da6df0237e3ac3ba5a70b5 100755 (executable)
@@ -21,13 +21,18 @@ fi
 if [ $STATE = "0" ]; then
    echo "lanscape"
    killall mbinputmgr
-   xrand -o normal
+# urg mbinputmgr should kill below
+   killall matchbox-keyboard
+   killall matchbox-stroke
+   xrandr -o normal
    exit 0
 fi
 
 if [ $STATE = "2" ]; then
    echo "portrait"
+   xrandr -o left 
+# just to be extra safe
+   sleep 1 
    mbinputmgr &
-   xrandr -o left
    exit 0
 fi
\ No newline at end of file