]> code.ossystems Code Review - openembedded-core.git/commitdiff
valgrind: drop mips n32 support
authorRandy MacLeod <Randy.MacLeod@windriver.com>
Wed, 7 Nov 2018 17:59:22 +0000 (12:59 -0500)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 9 Nov 2018 15:27:04 +0000 (15:27 +0000)
valgrind for qemumips64 multilib builds fails to configure
for libn32 with the error:
   configure:6190: checking for 32 bit build support
   ...
   fatal error: bits/long-double-32.h: No such file or directory
It seems that the toolchain is producing:
   tmp-glibc/sysroots-components/mips64-n32/libn32-glibc/usr/include/bits/long-double-n32.h

Until the toolchain problem is resolved, skip valgrind for libn32.

Signed-off-by: Randy MacLeod <Randy.MacLeod@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-core/packagegroups/packagegroup-core-tools-profile.bb
meta/recipes-devtools/valgrind/valgrind_3.14.0.bb

index 4ec1f9284f2f9bfa2c24e399e906c2cb6467faba..33d9c09a66f747b398b2d966455745519c443c82 100644 (file)
@@ -63,6 +63,7 @@ VALGRIND_armeb = ""
 VALGRIND_aarch64 = ""
 VALGRIND_riscv64 = ""
 VALGRIND_linux-gnux32 = ""
+VALGRIND_linux-gnun32 = ""
 
 RDEPENDS_${PN} = "\
     ${PROFILETOOLS} \
index 7f0a93f6f897da5181d2cf869fa7c2a35b201149..97e58a446a601ba4ddb9347f7ebe887e3219ff8c 100644 (file)
@@ -54,6 +54,7 @@ COMPATIBLE_HOST_linux-muslx32 = 'null'
 
 # Disable for some MIPS variants
 COMPATIBLE_HOST_mipsarchr6 = 'null'
+COMPATIBLE_HOST_linux-gnun32 = 'null'
 
 inherit autotools ptest multilib_header