]> code.ossystems Code Review - openembedded-core.git/commitdiff
kernel.bbclass: Add support for perf-dbg package
authorMark Hatle <mark.hatle@windriver.com>
Mon, 20 Jun 2011 17:58:45 +0000 (12:58 -0500)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 23 Jun 2011 11:05:11 +0000 (12:05 +0100)
The perf component is built with the kernel, so ensure that it gets the
debug information associated with it.

Also bump the PR in the linux-yocto-* to ensure they get rebuilt.

Signed-off-by: Mark Hatle <mark.hatle@windriver.com>
meta/classes/kernel.bbclass
meta/recipes-kernel/linux/linux-yocto_2.6.34.bb
meta/recipes-kernel/linux/linux-yocto_2.6.37.bb

index 1bb69f51360a73a2444622ddeef0a60f22d09a92..aaf341b75c1529bab97e9cab81a75294bc0652a0 100644 (file)
@@ -496,6 +496,7 @@ addtask deploy before do_build after do_install
 EXPORT_FUNCTIONS do_deploy
 
 # perf must be enabled in individual kernel recipes
-PACKAGES =+ "perf"
+PACKAGES =+ "perf-dbg perf"
 FILES_perf = "${bindir}/* \
               ${libexecdir}"
+FILES_perf-dbg = "${FILES_${PN}-dbg}"
index 66991aededb02a3692379f98c22bc4c2b3da3280..4891463c03f7e2877d79fc0aebd1d965983c6f5d 100644 (file)
@@ -22,7 +22,7 @@ SRCREV_machine_qemux86-64 = "72ca49ab08b8eb475cec82a10049503602325791"
 SRCREV_machine = "72ca49ab08b8eb475cec82a10049503602325791"
 SRCREV_meta = "ec26387cb168e9e0976999b528b5a9dd62e3157a"
 
-PR = "r1"
+PR = "r2"
 PV = "${LINUX_VERSION}+git${SRCPV}"
 SRCREV_FORMAT = "meta_machine"
 
index f244226e5276f47f71c64ab45ba4c93ca0a831db..90dc93094d2deb3829e4f6d352f93d3164b0cfe3 100644 (file)
@@ -22,7 +22,7 @@ SRCREV_machine_qemux86-64 = "790b4cd5ff0bb8c4f4523763436efd438c692342"
 SRCREV_machine = "bb8e31f2c99f5e007660d4540df246fb7ecfa746"
 SRCREV_meta = "d5d3c6480d61f83503ccef7fbcd765f7aca8b71b"
 
-PR = "r19"
+PR = "r20"
 PV = "${LINUX_VERSION}+git${SRCPV}"
 SRCREV_FORMAT = "meta_machine"