]> code.ossystems Code Review - openembedded-core.git/commitdiff
Fix alsa-utils package dependencies
authorDaniel Lazzari <dlazzari@leapfrog.com>
Tue, 20 Sep 2011 23:15:42 +0000 (23:15 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 21 Sep 2011 12:32:34 +0000 (13:32 +0100)
Make alsa-utils main package depend on all of the more specific alsa-utils packages (such as alsa-utils-alsamixer).

Signed-off-by: Daniel Lazzari Jr <dlazzari@leapfrog.com>
PR Bump

Signed-off-by: Saul Wold <sgw@linux.intel.com>
meta/recipes-multimedia/alsa/alsa-utils_1.0.24.2.bb

index 52a78714362624903111a811b1aa3002c69f1aeb..1b3ffe11b4b4f53f0772a1db6915c7ab8aec9d2b 100644 (file)
@@ -6,7 +6,7 @@ LICENSE = "GPLv2+"
 LIC_FILES_CHKSUM = "file://COPYING;md5=393a5ca445f6965873eca0259a17f833 \
                     file://alsactl/utils.c;beginline=1;endline=20;md5=fe9526b055e246b5558809a5ae25c0b9"
 DEPENDS = "alsa-lib ncurses"
-PR = "r1"
+PR = "r2"
 
 SRC_URI = "ftp://ftp.alsa-project.org/pub/utils/alsa-utils-${PV}.tar.bz2 \
            file://ncursesfix.patch \
@@ -28,7 +28,7 @@ inherit autotools gettext
 # This are all packages that we need to make. Also, the now empty alsa-utils
 # ipk depends on them.
 
-PACKAGES += "\
+ALSA_UTILS_PKGS = "\
              alsa-utils-alsamixer \
              alsa-utils-midi \
              alsa-utils-aplay \
@@ -44,6 +44,9 @@ PACKAGES += "\
              alsa-utils-alsaucm \
             "
 
+PACKAGES += "${ALSA_UTILS_PKGS}"
+RDEPENDS_${PN} += "${ALSA_UTILS_PKGS}"
+
 # We omit alsaconf, because
 # a) this is a bash script
 # b) it creates config files not suitable for OE-based distros