]> code.ossystems Code Review - openembedded-core.git/commitdiff
watchdog: Upgrade 5.12 -> 5.13
authorKhem Raj <raj.khem@gmail.com>
Tue, 12 Mar 2013 05:32:45 +0000 (22:32 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 15 Mar 2013 01:52:54 +0000 (01:52 +0000)
Part of ping failure patch is already applied
in 5.13 hence refreshed the patch.
Tested on x86_64 box

Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Saul Wold <sgw@linux.intel.com>
meta/recipes-extended/watchdog/files/fix-ping-failure.patch
meta/recipes-extended/watchdog/watchdog_5.13.bb [moved from meta/recipes-extended/watchdog/watchdog_5.12.bb with 78% similarity]

index c6ee84345e47fd0b7db193ea9925d5b29f2bc735..f5976eb5cfc2d582eeb20f64cb55867e08963d3b 100644 (file)
@@ -33,19 +33,10 @@ Signed-off-by: Roy.Li <rongqing.li@windriver.com>
  src/watchdog.c |    5 ++++-
  2 files changed, 5 insertions(+), 2 deletions(-)
 
---- a/src/net.c
-+++ b/src/net.c
-@@ -118,7 +118,7 @@ int check_net(char *target, int sock_fp,
-                   dtimeout.tv_usec -= 1000000;
-                   dtimeout.tv_sec++;
-               }
--              if (dtimeout.tv_sec <= 0)
-+              if (dtimeout.tv_sec < 0)
-                   break;
- #if USE_SYSLOG
-               if (verbose && logtick && ticker == 1)
---- a/src/watchdog.c
-+++ b/src/watchdog.c
+Index: watchdog-5.13/src/watchdog.c
+===================================================================
+--- watchdog-5.13.orig/src/watchdog.c  2013-02-01 03:15:44.000000000 -0800
++++ watchdog-5.13/src/watchdog.c       2013-03-11 22:27:48.741657881 -0700
 @@ -28,6 +28,7 @@
  #include <sys/types.h>
  #include <sys/ioctl.h>
@@ -54,7 +45,7 @@ Signed-off-by: Roy.Li <rongqing.li@windriver.com>
  #include <linux/watchdog.h>
  #include <string.h>
  
-@@ -567,6 +568,8 @@ int main(int argc, char *const argv[])
+@@ -567,6 +568,8 @@
      pid_t child_pid;
      int oom_adjusted = 0;
      struct stat s;
@@ -63,7 +54,7 @@ Signed-off-by: Roy.Li <rongqing.li@windriver.com>
  
  #if USE_SYSLOG
      char *opts = "d:i:n:Ffsvbql:p:t:c:r:m:a:";
-@@ -703,7 +706,7 @@ int main(int argc, char *const argv[])
+@@ -703,7 +706,7 @@
                perror(progname);
                exit(1);
            }
similarity index 78%
rename from meta/recipes-extended/watchdog/watchdog_5.12.bb
rename to meta/recipes-extended/watchdog/watchdog_5.13.bb
index 78262b80e4ac1609a6528fee880bfd8d859db6c0..610e4735bb66c3eb330cec77cd870ebf340a3788 100644 (file)
@@ -8,13 +8,10 @@ BUGTRACKER = "http://sourceforge.net/tracker/?group_id=172030&atid=860194"
 LICENSE = "GPL-2.0+"
 LIC_FILES_CHKSUM = "file://COPYING;md5=ecc0551bf54ad97f6b541720f84d6569"
 
-PR = "r1"
-
 SRC_URI = "${SOURCEFORGE_MIRROR}/watchdog/watchdog-${PV}.tar.gz \
           file://fix-ping-failure.patch"
-
-SRC_URI[md5sum] = "cea28bea70e54f3625062bc808aef9af"
-SRC_URI[sha256sum] = "862d5da6ab34568bbd4ea695316f063fecabe107d0939ceea6c67c9ec0b1a08e"
+SRC_URI[md5sum] = "153455f008f1cf8f65f6ad9586a21ff1"
+SRC_URI[sha256sum] = "141e0faf3ee4d8187a6ff4e00b18ef7b7a4ce432a2d4c8a6e6fdc62507fc6eb0"
 
 inherit autotools