]> code.ossystems Code Review - openembedded-core.git/commitdiff
bash: Use new _ptest functions
authorBjörn Stenberg <bjst@enea.com>
Wed, 6 Mar 2013 09:41:11 +0000 (10:41 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 7 Mar 2013 11:12:57 +0000 (11:12 +0000)
Signed-off-by: Björn Stenberg <bjst@enea.com>
Signed-off-by: Saul Wold <sgw@linux.intel.com>
meta/recipes-extended/bash/bash.inc

index 20a23f030fe5cb573c82c971995e2ef8a7e8d58c..c619f824e9c178bfc77dc891b5b3bf0f7952afb4 100644 (file)
@@ -25,10 +25,8 @@ do_configure_prepend () {
        fi
 }
 
-do_compile_append () {
-        if [ "${PN}" = "${BPN}" -a ${PTEST_ENABLED} = "1" ]; then
-            oe_runmake buildtest
-        fi
+do_compile_ptest () {
+       oe_runmake buildtest
 }
 
 do_install_append () {
@@ -37,12 +35,11 @@ do_install_append () {
                mkdir -p ${D}${base_bindir}
                mv ${D}${bindir}/bash ${D}${base_bindir}
        fi
+}
 
-        if [ "${PN}" = "${BPN}" -a ${PTEST_ENABLED} = "1" ]; then
-            ptest_do_install
-            make INSTALL_TEST_DIR=${D}${PTEST_PATH}/tests install-test
-            cp ${B}/Makefile ${D}${PTEST_PATH}
-        fi
+do_install_ptest () {
+       make INSTALL_TEST_DIR=${D}${PTEST_PATH}/tests install-test
+       cp ${B}/Makefile ${D}${PTEST_PATH}
 }
 
 pkg_postinst_${PN} () {