]> code.ossystems Code Review - openembedded-core.git/commitdiff
watchdog: disable systemd services by default
authorChen Qi <Qi.Chen@windriver.com>
Wed, 13 Jun 2018 07:58:21 +0000 (15:58 +0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 18 Jun 2018 09:59:33 +0000 (10:59 +0100)
systemd has internal support for watchdog. See the RuntimeWatchdogSec
in /etc/systemd/system.conf.

We'd better just disable this service by default. If users want to use
watchdog, consider using the systemd one.

Signed-off-by: Chen Qi <Qi.Chen@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-extended/watchdog/watchdog_5.15.bb

index d3f03532ac0f51ec6c966e9b3065224bbbead1ef..bfaed9ad96dadea13af790671147568104dc59e9 100644 (file)
@@ -40,6 +40,9 @@ INITSCRIPT_PARAMS_${PN}-keepalive = "start 15 1 2 3 4 5 . stop 85 0 6 ."
 SYSTEMD_PACKAGES = "${PN} ${PN}-keepalive"
 SYSTEMD_SERVICE_${PN} = "watchdog.service"
 SYSTEMD_SERVICE_${PN}-keepalive = "wd_keepalive.service"
+# When using systemd, consider making use of internal watchdog support of systemd.
+# See RuntimeWatchdogSec in /etc/systemd/system.conf.
+SYSTEMD_AUTO_ENABLE = "disable"
 
 do_install_append() {
        install -d ${D}${systemd_system_unitdir}