]> code.ossystems Code Review - openembedded-core.git/commitdiff
gcc-4.5.0: import some ppc & mips fixes from oe recipes
authorNitin A Kamble <nitin.a.kamble@intel.com>
Fri, 30 Jul 2010 21:05:16 +0000 (14:05 -0700)
committerRichard Purdie <rpurdie@linux.intel.com>
Tue, 10 Aug 2010 14:02:09 +0000 (15:02 +0100)
for ppc glibc build failes with -os (optimize for size) gcc option. so
 the fix disables this gcc options on ppc.

MIPS fix is added in the hope of helping webkit-gtk build failure (gcc
seg fault).

And fix the PR bumps for all affected recipes

Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com>
13 files changed:
meta/packages/gcc/gcc-common.inc
meta/packages/gcc/gcc-configure-common.inc
meta/packages/gcc/gcc-cross-canadian_4.5.0.bb
meta/packages/gcc/gcc-cross-initial.inc
meta/packages/gcc/gcc-cross-initial_4.5.0.bb
meta/packages/gcc/gcc-cross-intermediate.inc
meta/packages/gcc/gcc-cross-intermediate_4.5.0.bb
meta/packages/gcc/gcc-cross_4.5.0.bb
meta/packages/gcc/gcc-crosssdk-initial_4.5.0.bb
meta/packages/gcc/gcc-crosssdk-intermediate_4.5.0.bb
meta/packages/gcc/gcc-crosssdk_4.5.0.bb
meta/packages/gcc/gcc-runtime_4.5.0.bb
meta/packages/gcc/gcc_4.5.0.bb

index ea0a48ea0cc62d59625bcf7b8805585a344428cb..1e9c65e66259cac62b3e7807114fbb9ecae998ac 100644 (file)
@@ -14,6 +14,11 @@ def get_gcc_fpu_setting(bb, d):
         return "--with-float=soft"
     return ""
 
+def get_gcc_mips_plt_setting(bb, d):
+    if bb.data.getVar('TARGET_ARCH', d, 1) in [ 'mips', 'mipsel' ] and 'mplt' in bb.data.getVar('DISTRO_FEATURES',d,1).split() :
+        return "--with-mips-plt"
+    return ""
+
 # We really need HOST_SYS here for some packages and TARGET_SYS for others.
 # For now, libgcc is most important so we fix for that - RP.
 SHLIBSDIR = "${STAGING_DIR_TARGET}/shlibs"
index 3400296c2d56c211433931c4f1290d921d40e90f..ab42bc56087bc2a73d79ede7d2825de33c54156b 100644 (file)
@@ -12,6 +12,12 @@ JAVA_sh3 ?= ""
 # gcc 3.x expects 'f77', 4.0 expects 'f95', 4.1 and 4.2 expect 'fortran'
 FORTRAN ?= ",f77"
 LANGUAGES ?= "c,c++${FORTRAN}${JAVA}"
+# disable --enable-target-optspace for powerpc SPE
+# at -Os libgcc.so.1 creates references into
+# hidden symbols in libgcc.a which linker complains
+# when linking shared libraries further in the build like (gnutls)
+
+OPTSPACE = "${@base_contains('TARGET_ARCH', 'powerpc', '', '--enable-target-optspace',d)}"
 
 EXTRA_OECONF_BASE ?= ""
 EXTRA_OECONF_PATHS ?= ""
@@ -23,7 +29,6 @@ GCCMULTILIB = "--disable-multilib"
 EXTRA_OECONF = "${@['--enable-clocale=generic', ''][bb.data.getVar('USE_NLS', d, 1) != 'no']} \
                 --with-gnu-ld \
                 --enable-shared \
-                --enable-target-optspace \
                 --enable-languages=${LANGUAGES} \
                 --enable-threads=posix \
                 ${GCCMULTILIB} \
@@ -32,9 +37,11 @@ EXTRA_OECONF = "${@['--enable-clocale=generic', ''][bb.data.getVar('USE_NLS', d,
                 --enable-symvers=gnu \
                 --enable-libstdcxx-pch \
                 --program-prefix=${TARGET_PREFIX} \
+                ${OPTSPACE} \
                 ${EXTRA_OECONF_BASE} \
                 ${EXTRA_OECONF_FPU} \
-                ${EXTRA_OECONF_PATHS}"
+                ${EXTRA_OECONF_PATHS} \
+                ${@get_gcc_mips_plt_setting(bb, d)}"
 
 # Build uclibc compilers without cxa_atexit support
 EXTRA_OECONF_append_linux               = " --enable-__cxa_atexit"
index 3eea4bcafede92b9382266010de75b307c338d2c..92708d44e7db04525066dc29b0ca84a81011e9bd 100644 (file)
@@ -5,7 +5,7 @@ require gcc-cross-canadian.inc
 require gcc-configure-sdk.inc
 require gcc-package-sdk.inc
 
-PR = "r3"
+PR = "r4"
 
 DEPENDS += "gmp-nativesdk mpfr-nativesdk libmpc-nativesdk elfutils-nativesdk"
 RDEPENDS_${PN} += "mpfr-nativesdk libmpc-nativesdk elfutils-nativesdk"
index ceedb6f8a93e33ed32a08d05c168b06bebae595e..f582de984301a324dfd8e6eb598022e730ef7917 100644 (file)
@@ -12,7 +12,7 @@ EXTRA_OECONF = "--with-local-prefix=${STAGING_DIR_TARGET}${target_prefix} \
                --disable-multilib \
                --disable-__cxa_atexit \
                --enable-languages=c \
-               --enable-target-optspace \
+                ${OPTSPACE} \
                --program-prefix=${TARGET_PREFIX} \
                --with-sysroot=${STAGING_DIR_TARGET} \
                --with-build-sysroot=${STAGING_DIR_TARGET} \
index 38e0964fedc8b8c50ad63849863e8ff216edea44..081b7d60fb5946d582bc1423e1e549b731972787 100644 (file)
@@ -1,5 +1,5 @@
 require gcc-cross_${PV}.bb
 require gcc-cross-initial.inc
 
-PR = "r3"
+PR = "r4"
 
index bab9d4a22414cc536c5ea1d836969c0dfaa83e36..72a42411b17b98e90d9d63c5a0a27189dcc6d7c4 100644 (file)
@@ -10,7 +10,7 @@ EXTRA_OECONF = "--with-local-prefix=${STAGING_DIR_TARGET}${target_prefix} \
                --disable-multilib \
                --disable-threads \
                --enable-languages=c \
-               --enable-target-optspace \
+                ${OPTSPACE} \
                --program-prefix=${TARGET_PREFIX} \
                --with-sysroot=${STAGING_DIR_TARGET} \
                --with-build-sysroot=${STAGING_DIR_TARGET} \
index e65d5df671789da6dd819783b32ac602bba79996..9a30cb51195a5376bff61bc8390e0978aaa36b3c 100644 (file)
@@ -1,4 +1,4 @@
 require gcc-cross_${PV}.bb
 require gcc-cross-intermediate.inc
-PR = "r3"
+PR = "r4"
 
index 3d75bd4a195bf3151fec6bc1e87e9446720e5d0a..04e4f8d21214afbd7d66fe9be3f6fe51a0796e9b 100644 (file)
@@ -1,4 +1,4 @@
-PR = "r3"
+PR = "r4"
 
 require gcc-${PV}.inc
 require gcc-cross4.inc
index fec53b931cd0145fe1540d36fc2951a49d56ae65..970824805fcf196ab312bb41663eea8b01a25db8 100644 (file)
@@ -1,4 +1,4 @@
 require gcc-cross-initial_${PV}.bb
 require gcc-crosssdk-initial.inc
 
-PR = "r3"
+PR = "r4"
index 161d870e639958f91e930ca9ddce11f69733a147..d23596959139503c9115e70b81ef1649eeae1bb7 100644 (file)
@@ -1,4 +1,4 @@
 require gcc-cross-intermediate_${PV}.bb
 require gcc-crosssdk-intermediate.inc
 
-PR = "r3"
+PR = "r4"
index 70690881aa57a17eb5e9b91f3fe3349baf0ec62c..bae238970a6a365598961a98016946407bd58ed1 100644 (file)
@@ -1,4 +1,4 @@
 require gcc-cross_${PV}.bb
 require gcc-crosssdk.inc
 
-PR = "r3"
+PR = "r4"
index c1e680d3c04eff5ae62e6a581302a32306312200..9eb658b12c29697b8b17a6b199299106899299b0 100644 (file)
@@ -1,4 +1,4 @@
-PR = "r3"
+PR = "r4"
 
 require gcc-${PV}.inc
 require gcc-configure-runtime.inc
index 7c1869f503b2d0c5bb06c0a961edd63a18d6c846..c14914cddbd9b80ae84f4f657ac4eb0c126159df 100644 (file)
@@ -1,4 +1,4 @@
-PR = "r3"
+PR = "r4"
 
 require gcc-${PV}.inc
 require gcc-configure-target.inc