]> code.ossystems Code Review - openembedded-core.git/commitdiff
telepathy-python: Fix parallel make issue.
authorDongxiao Xu <dongxiao.xu@intel.com>
Thu, 10 Mar 2011 01:15:06 +0000 (09:15 +0800)
committerSaul Wold <sgw@linux.intel.com>
Fri, 11 Mar 2011 01:10:50 +0000 (17:10 -0800)
There is a missing dependency (creation of "src/_generated" directory)
of some tasks. Add it to fix the parallel make issue.

[YOCTO #783]

Signed-off-by: Dongxiao Xu <dongxiao.xu@intel.com>
meta/recipes-connectivity/telepathy/telepathy-python-0.15.19/parallel_make.patch [new file with mode: 0644]
meta/recipes-connectivity/telepathy/telepathy-python_0.15.19.bb

diff --git a/meta/recipes-connectivity/telepathy/telepathy-python-0.15.19/parallel_make.patch b/meta/recipes-connectivity/telepathy/telepathy-python-0.15.19/parallel_make.patch
new file mode 100644 (file)
index 0000000..145e17b
--- /dev/null
@@ -0,0 +1,40 @@
+Add dependency of __init__.py
+
+Tasks must be done after exec of __init__, which creates the
+src/_generated directory that tasks are based on.
+
+Signed-off-by: Dongxiao Xu <dongxiao.xu@intel.com>
+
+diff -ruN telepathy-python-0.15.19-orig/src/Makefile.am telepathy-python-0.15.19/src/Makefile.am
+--- telepathy-python-0.15.19-orig/src/Makefile.am      2011-03-10 08:51:49.000000000 +0800
++++ telepathy-python-0.15.19/src/Makefile.am   2011-03-10 08:54:45.000000000 +0800
+@@ -39,17 +39,17 @@
+ XSLTPROC_OPTS = --nonet --novalid --xinclude
+ tools_dir = $(top_srcdir)/tools
+-_generated/interfaces.py: $(tools_dir)/python-interfaces-generator.xsl $(wildcard $(spec_dir)/*.xml)
++_generated/interfaces.py: _generated/__init__.py $(tools_dir)/python-interfaces-generator.xsl $(wildcard $(spec_dir)/*.xml)
+       $(AM_V_GEN)$(XSLTPROC) $(XSLTPROC_OPTS) -o $@ \
+           $(tools_dir)/python-interfaces-generator.xsl \
+           $(spec_dir)/all.xml
+-_generated/constants.py: $(tools_dir)/python-constants-generator.xsl $(wildcard $(spec_dir)/*.xml)
++_generated/constants.py: _generated/__init__.py $(tools_dir)/python-constants-generator.xsl $(wildcard $(spec_dir)/*.xml)
+       $(AM_V_GEN)$(XSLTPROC) $(XSLTPROC_OPTS) -o $@ \
+           $(tools_dir)/python-constants-generator.xsl \
+           $(spec_dir)/all.xml
+-_generated/errors.py: $(tools_dir)/python-errors-generator.xsl $(wildcard $(spec_dir)/*.xml)
++_generated/errors.py: _generated/__init__.py $(tools_dir)/python-errors-generator.xsl $(wildcard $(spec_dir)/*.xml)
+       $(AM_V_GEN)$(XSLTPROC) $(XSLTPROC_OPTS) -o $@ \
+           $(tools_dir)/python-errors-generator.xsl \
+           $(spec_dir)/all.xml
+@@ -58,7 +58,7 @@
+       $(AM_V_GEN)$(mkdir_p) $(dir $@)
+       @echo "# Placeholder for package" > $@
+-_generated/%.py: $(tools_dir)/spec-to-python.xsl $(spec_dir)/%.xml
++_generated/%.py: _generated/__init__.py $(tools_dir)/spec-to-python.xsl $(spec_dir)/%.xml
+       $(AM_V_GEN)$(XSLTPROC) $(XSLTPROC_OPTS) -o $@ \
+           $(tools_dir)/spec-to-python.xsl \
+           $(spec_dir)/$*.xml
index aefde8c891e0f8a5365fbbabc22ac28b27bec9cf..7c833938990b78b9122b151fa397ef192ad34530 100644 (file)
@@ -6,9 +6,10 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=2d5025d4aa3495befef8f17206a5b0a1 \
 
 RDEPENDS_${PN} += "python-dbus"
 
-SRC_URI = "http://telepathy.freedesktop.org/releases/${PN}/${P}.tar.gz "
+SRC_URI = "http://telepathy.freedesktop.org/releases/${PN}/${P}.tar.gz \
+           file://parallel_make.patch"
 
-PR = "r0"
+PR = "r1"
 
 inherit autotools