]> code.ossystems Code Review - openembedded-core.git/commitdiff
Split development tools into separate task and add new oh-image-devel target
authorRichard Purdie <richard@openedhand.com>
Wed, 22 Mar 2006 11:43:46 +0000 (11:43 +0000)
committerRichard Purdie <richard@openedhand.com>
Wed, 22 Mar 2006 11:43:46 +0000 (11:43 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@321 311d38ba-8fff-0310-9ca6-ca027cbcb966

openembedded/packages/meta/oh-image-devel.bb [new file with mode: 0644]
openembedded/packages/meta/task-oh.bb

diff --git a/openembedded/packages/meta/oh-image-devel.bb b/openembedded/packages/meta/oh-image-devel.bb
new file mode 100644 (file)
index 0000000..3adfae7
--- /dev/null
@@ -0,0 +1,23 @@
+PR = "r9"
+
+export IMAGE_BASENAME = "oh-devel"
+
+GUI_MACHINE_CLASS ?= "none"
+
+XSERVER ?= "xserver-kdrive-fbdev"
+
+DEPENDS = "\
+    task-bootstrap \
+    task-oh"
+    
+RDEPENDS = "\
+    task-bootstrap \
+    task-oh-base \
+    task-oh-devel \
+    ${XSERVER} "
+
+export IPKG_INSTALL = "${RDEPENDS}"
+#ROOTFS_POSTPROCESS_COMMAND += "zap_root_password; "
+
+inherit image_ipk
+LICENSE = MIT
index d691d43201342a267e52e382362454b11fc0b6a6..9840e8d3616cdfedcf527e6429229cd39d097ad1 100644 (file)
@@ -1,14 +1,10 @@
-PACKAGES = "task-oh-base-depends task-oh-base"
+PACKAGES = "task-oh-base task-oh-devel"
 DESCRIPTION = "Tasks for OpenedHand Poky"
 MAINTAINER = "Richard Purdie <richard@openedhand.com>"
-PR = "r23"
+PR = "r24"
 
 ALLOW_EMPTY = "1"
 
-RDEPENDS_task-oh-base-depends := "\
-    diet-x11 \
-    virtual/xserver"
-
 RDEPENDS_task-oh-base := "\
     matchbox \
     matchbox-poky \
@@ -39,9 +35,6 @@ RDEPENDS_task-oh-base := "\
     kf \
     rxvt-unicode \
     xhost \
-#    oprofile \
-#    gdb \    
-    strace \
     ttf-bitstream-vera \
     udev \
     sysfsutils \
@@ -55,13 +48,9 @@ RDEPENDS_task-oh-base := "\
     gnome-vfs-plugin-file \
     gnome-vfs-plugin-http \
     gtk-theme-clearlooks \
-    kernel-module-oprofile \
-    tslib-calibrate \
-    tslib-tests \
     pango-module-basic-x \
     pango-module-basic-fc"
 
-
 #    minimo \
 #    teleport \
 #    xst \
@@ -69,4 +58,18 @@ RDEPENDS_task-oh-base := "\
 #    detect-stylus \
 #    xrdb \
 
+
+RDEPENDS_task-oh-devel := "\
+    tslib-calibrate \
+    tslib-tests \
+    oprofile \
+    gdb \    
+    strace \
+    lttng-viewer"
+
+RRECOMMENDS_task-oh-devel := "\
+    kernel-module-oprofile"
+#    lttng-modules
+
+
 LICENSE = "MIT"