]> code.ossystems Code Review - openembedded-core.git/commitdiff
udev: Allow standard users to access shared memory
authorRichard Purdie <rpurdie@linux.intel.com>
Sun, 31 May 2009 21:16:48 +0000 (22:16 +0100)
committerRichard Purdie <rpurdie@linux.intel.com>
Sun, 31 May 2009 21:16:48 +0000 (22:16 +0100)
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
meta/packages/udev/udev-141/init
meta/packages/udev/udev_141.bb

index 0e1a9d96e68fe6aa070bf5b34df6d0020bee342a..f38a0aa36e63b1ac650451d1120b8218c3674e8d 100644 (file)
@@ -31,7 +31,7 @@ echo -n "Starting udev"
 LANG=C awk "\$2 == \"/dev\" && \$4 == \"tmpfs\" { exit 1 }" /proc/mounts && {
         mount -n -o mode=0755 -t tmpfs none "/dev"
         mkdir -m 0755 /dev/pts
-        mkdir -m 0755 /dev/shm
+        mkdir -m 1777 /dev/shm
 }
 
 if [ -e /etc/dev.tar ]; then
index ab2bc348145c759831a6d231b0e9565763eb0e86..5476195ea290a8669d15843c1cdedfb49f341923 100644 (file)
@@ -3,7 +3,7 @@ DESCRIPTION = "udev is a daemon which dynamically creates and removes device nod
 the hotplug package and requires a kernel not older than 2.6.12."
 RPROVIDES_${PN} = "hotplug"
 
-PR = "r3"
+PR = "r4"
 
 SRC_URI = "http://kernel.org/pub/linux/utils/kernel/hotplug/udev-${PV}.tar.gz \
           file://noasmlinkage.patch;patch=1 \