]> code.ossystems Code Review - openembedded-core.git/commitdiff
libxslt: fix packaging of static libraries
authorPhil Blundell <philb@gnu.org>
Wed, 17 Aug 2011 13:56:53 +0000 (14:56 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 19 Aug 2011 16:05:52 +0000 (09:05 -0700)
This prevents warnings about .a files being installed but not shipped.

Signed-off-by: Phil Blundell <philb@gnu.org>
meta/recipes-support/libxslt/libxslt_1.1.26.bb

index b5f6962e9c1fee0782b112f522ec47e8b36ff433..cc64ba741e7001e257ad6b9e9cfcd4d61b591b57 100644 (file)
@@ -6,8 +6,8 @@ LICENSE = "MIT"
 LIC_FILES_CHKSUM = "file://COPYING;md5=0cd9a07afbeb24026c9b03aecfeba458"
 
 SECTION = "libs"
-DEPENDS = "libxml2 (>=2.6.27)"
-PR = "r1"
+DEPENDS = "libxml2"
+PR = "r2"
 
 SRC_URI = "ftp://xmlsoft.org/libxslt//libxslt-${PV}.tar.gz \
            file://pkgconfig_fix.patch;patch=1"
@@ -16,13 +16,14 @@ SRC_URI[md5sum] = "e61d0364a30146aaa3001296f853b2b9"
 SRC_URI[sha256sum] = "55dd52b42861f8a02989d701ef716d6280bfa02971e967c285016f99c66e3db1"
 S = "${WORKDIR}/libxslt-${PV}"
 
-inherit autotools pkgconfig binconfig
+inherit autotools pkgconfig binconfig lib_package
 
 EXTRA_OECONF = "--without-python --without-debug --without-mem-debug --without-crypto"
+# older versions of this recipe had ${PN}-utils
+RPROVIDES_${PN}-bin += "${PN}-utils"
+RCONFLICTS_${PN}-bin += "${PN}-utils"
+RREPLACES_${PN}-bin += "${PN}-utils"
 
-PACKAGES = "${PN}-dbg ${PN}-dev ${PN}-utils ${PN} ${PN}-doc ${PN}-locale"
-
-FILES_${PN}-dev += "${bindir}/xslt-config"
-FILES_${PN}-utils += "${bindir}"
+FILES_${PN}-dev += "${bindir}/xsltConf.sh"
 
 BBCLASSEXTEND = "native"