]> code.ossystems Code Review - openembedded-core.git/commitdiff
openjade-native: Add SYSROOT_PREPROCESS_FUNC
authorSaul Wold <sgw@linux.intel.com>
Fri, 22 Jul 2011 23:38:09 +0000 (16:38 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 25 Jul 2011 11:38:41 +0000 (12:38 +0100)
[YOCTO #1250]

This added function will install a private install-catalog binary so that shared state
can find the binary as there is not a guarantee.

Signed-off-by: Saul Wold <sgw@linux.intel.com>
meta/recipes-devtools/openjade/openjade-native_1.3.2.bb

index 1c672e109e1bae8f31920d1c73f0ad00bb9c1bb5..da59406aa956090869ef0c982f9002b52050f4e5 100644 (file)
@@ -7,7 +7,7 @@ SECTION = "base"
 LICENSE = "BSD"
 LIC_FILES_CHKSUM = "file://COPYING;md5=641ff1e4511f0a87044ad42f87cb1045"
 
-PR = "r2"
+PR = "r3"
 
 DEPENDS = "opensp-native sgml-common-native"
 RDEPENDS_${PN} = "sgml-common"
@@ -31,6 +31,8 @@ CONFIGUREOPTS := "${@d.getVar('CONFIGUREOPTS', True).replace('--datadir=${datadi
 CFLAGS =+ "-I${S}/include"
 
 SSTATEPOSTINSTFUNCS += "openjade_sstate_postinst"
+SYSROOT_PREPROCESS_FUNCS += "openjade_sysroot_preprocess"
+
 
 # We need to do this else the source interdependencies aren't generated and
 # build failures can result (e.g. zero size style/Makefile.dep file)
@@ -66,8 +68,14 @@ openjade_sstate_postinst() {
        then
                # Ensure that the catalog file sgml-docbook.cat is properly
                # updated when the package is installed from sstate cache.
-               install-catalog \
+               ${SYSROOT_DESTDIR}${bindir_crossscripts}/install-catalog-openjade \
                        --add ${sysconfdir}/sgml/sgml-docbook.cat \
                        ${sysconfdir}/sgml/openjade-${PV}.cat
        fi
 }
+
+openjade_sysroot_preprocess () {
+    install -d ${SYSROOT_DESTDIR}${bindir_crossscripts}/
+    install -m 755 ${STAGING_BINDIR_NATIVE}/install-catalog ${SYSROOT_DESTDIR}${bindir_crossscripts}/install-catalog-openjade
+}
+