]> code.ossystems Code Review - openembedded-core.git/commitdiff
strace: drop unnecessary dependency on acl
authorAndre McCurdy <armccurdy@gmail.com>
Mon, 18 Jan 2016 21:33:48 +0000 (13:33 -0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 20 Jan 2016 09:20:05 +0000 (09:20 +0000)
The dependency on acl was removed from strace prior to the v4.10
release, so it's no longer necessary to add a configure option to
allow acl to be disabled.

  http://sourceforge.net/p/strace/code/ci/681452b0f854833d4bd443fcd9bb0bab2b46339f

Signed-off-by: Andre McCurdy <armccurdy@gmail.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-devtools/strace/strace/strace-add-configure-options.patch
meta/recipes-devtools/strace/strace_4.10.bb

index e48e4b31b99c269fb6aa3f2c4c88501c5d5e2932..a3f8ec463dce1465c4feb1e80ab4e954e37be1da 100644 (file)
@@ -1,4 +1,4 @@
-Add options "aio" and "acl" to enable/disable libaio and acl support.
+Add option "aio" to enable/disable libaio support.
 
 Upstream-Status: Pending
 
@@ -12,26 +12,7 @@ diff --git a/configure.ac b/configure.ac
 index e73958c..9099370 100644
 --- a/configure.ac
 +++ b/configure.ac
-@@ -270,6 +270,18 @@ AC_CHECK_HEADERS(m4_normalize([
-       sys/vfs.h
-       sys/xattr.h
- ]))
-+
-+AC_ARG_ENABLE([acl],
-+      [AS_HELP_STRING([--enable-acl], [turn on acl support])],
-+      [case $enableval in
-+      yes)
-+              AC_CHECK_HEADERS([sys/acl.h])
-+              ;;
-+      no)  ;;
-+      *)   AC_MSG_ERROR([bad value $enableval for aio option]) ;;
-+      esac]
-+)
-+
- AC_CHECK_HEADERS([linux/icmp.h linux/in6.h linux/netlink.h linux/if_packet.h],
-                  [], [], [#include <stddef.h>
- #include <sys/socket.h>
-@@ -745,6 +757,20 @@ if test "x$ac_cv_lib_dl_dladdr" = xyes; then
+@@ -745,6 +745,20 @@ if test "x$ac_cv_lib_dl_dladdr" = xyes;
  fi
  AC_SUBST(dl_LIBS)
  
@@ -54,4 +35,3 @@ index e73958c..9099370 100644
  dnl stack trace with libunwind
 --
 1.9.1
-
index 20b7e3d0a578cbc225eed4beb1071b14f6963f7a..fe250b771c5464d20313971d6c6a1d02f6fac842 100644 (file)
@@ -21,12 +21,11 @@ inherit autotools ptest bluetooth
 RDEPENDS_${PN}-ptest += "make coreutils grep gawk"
 
 PACKAGECONFIG_class-target ??= "\
-    libaio ${@bb.utils.contains('DISTRO_FEATURES', 'acl', 'acl', '', d)} \
+    libaio \
     ${@bb.utils.contains('DISTRO_FEATURES', 'bluetooth', 'bluez', '', d)} \
 "
 
 PACKAGECONFIG[libaio] = "--enable-aio,--disable-aio,libaio"
-PACKAGECONFIG[acl] = "--enable-acl,--disable-acl,acl"
 PACKAGECONFIG[libunwind] = "--with-libunwind, --without-libunwind, libunwind"
 PACKAGECONFIG[bluez] = "ac_cv_header_bluetooth_bluetooth_h=yes,ac_cv_header_bluetooth_bluetooth_h=no,${BLUEZ}"