]> code.ossystems Code Review - openembedded-core.git/commitdiff
scripts/create-recipe: Bugfixes for create-recipe easy_install handling.
authorDavid Nyström <david.c.nystrom@gmail.com>
Thu, 7 Feb 2013 10:00:26 +0000 (11:00 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 8 Feb 2013 14:46:02 +0000 (14:46 +0000)
1. Tell easy_install to always download, regardless of python
   install content.
2. Support https/ftp et.c. URLs provided by easy_install

Signed-off-by: David Nyström <david.nystrom@enea.com>
Signed-off-by: Saul Wold <sgw@linux.intel.com>
scripts/create-recipe

index 1b10e1b5913cccdd01c18239257f1fe0762161b0..5613e92cb9aa357671c609e5ae34a4ba7f6b1801 100755 (executable)
@@ -1918,9 +1918,9 @@ if ( -e "$dir/setup.py" ) {
            if ($recurse_python == 1) {
                foreach (@rawpythondeps) {
                    my $ptempdir = tempdir();
-                   $purl = `easy_install -eb $ptempdir "$_" 2>/dev/null`;
-                   $purl =~ s/#.*//;
-                   @purllist = $purl =~ m/Downloading (http:\/\/.*\n)/g;
+                   $purl = `easy_install -aeb $ptempdir "$_" 2>/dev/null`;
+                   $purl =~ s/#.*//g;
+                   @purllist = $purl =~ m/Downloading (.*:\/\/.*\n)/g;
                    chomp(@purllist);
                    
                    # Remove empty lines