]> code.ossystems Code Review - openembedded-core.git/commitdiff
bitbake.conf: use ??= for IMAGE_ROOTFS_SIZE
authorChen Qi <Qi.Chen@windriver.com>
Thu, 4 Sep 2014 07:52:44 +0000 (15:52 +0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 10 Sep 2014 14:19:57 +0000 (15:19 +0100)
Previously, when building core-image-minimal, the rootfs size would
default to 64M because we use '?=' in bitbake.conf and also '?=' in
core-image-minimal.bb.

The thing is, we'd like to have a default value for all images set
in bitbake.conf but still allow each image recipe to set its own default
value which could be overridden by users in local.conf.

Signed-off-by: Chen Qi <Qi.Chen@windriver.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/conf/bitbake.conf

index 2771233e3ead75823e9a31e9d991a17d98320c7c..468b175edc643369034ea428ea060db805a8eab3 100644 (file)
@@ -689,7 +689,7 @@ MACHINE_TASK_PROVIDER ?= "${DEFAULT_TASK_PROVIDER}"
 # The size in Kbytes for the generated image if it is larger than
 # the required size (du -ks IMAGE_ROOTFS * IMAGE_OVERHEAD_FACTOR),
 # and no effect if less than it.
-IMAGE_ROOTFS_SIZE ?= "65536"
+IMAGE_ROOTFS_SIZE ??= "65536"
 
 # Forcefully set CACHE now so future changes to things like 
 # MACHINE don't change the path to the cache