]> code.ossystems Code Review - openembedded-core.git/commitdiff
chkconfig: fix QA warning about unsafe references in binaries
authorWenzong Fan <wenzong.fan@windriver.com>
Thu, 6 Jun 2013 09:28:10 +0000 (17:28 +0800)
committerSaul Wold <sgw@linux.intel.com>
Mon, 10 Jun 2013 21:51:25 +0000 (14:51 -0700)
This test is disabled in oe-core by default, but if we enable it, we'll
get following warnings:

  + WARN_QA = "unsafe-references-in-binaries unsafe-references-in-scripts"

WARNING: QA Issue: chkconfig: /sbin/chkconfig, installed in the \
base_prefix, requires a shared library under exec_prefix (/usr): \
libpopt.so.0 => /usr/lib64/libpopt.so.0

Signed-off-by: Wenzong Fan <wenzong.fan@windriver.com>
Signed-off-by: Saul Wold <sgw@linux.intel.com>
meta/recipes-extended/chkconfig/chkconfig_1.3.58.bb

index 4c6985fd39dab23dcf34daee81f191765deb1433..c6f8b1d44fd5b6044ea4d946c97d2c15a233029a 100644 (file)
@@ -43,7 +43,8 @@ obey_variables () {
 }
 
 do_install() {
-       oe_runmake 'DESTDIR=${D}' 'INSTALLNLSDIR=${D}${datadir}/locale' install
+       oe_runmake 'DESTDIR=${D}' 'INSTALLNLSDIR=${D}${datadir}/locale' \
+               'BINDIR=${sbindir}' install
        install -d ${D}${sysconfdir}/chkconfig.d
 }