]> code.ossystems Code Review - openembedded-core.git/commitdiff
binutils: Use configure options to disable gdb and dependencies
authorKhem Raj <raj.khem@gmail.com>
Sat, 4 Apr 2020 00:44:45 +0000 (17:44 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Sun, 5 Apr 2020 10:46:34 +0000 (11:46 +0100)
Deleting sources is a rough way of dealing with disabling components,
using configure option is elegant way and we also keep the sources
unchanged, this should not cause any funcitonal changes otherwise

Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/binutils/binutils-2.34.inc
meta/recipes-devtools/binutils/binutils.inc
meta/recipes-devtools/binutils/binutils_2.34.bb

index ed9f902fd28593a563e51dfd5d8db24a37029abe..4b085b6fe0808eb214c490830a6db28f5e2620a3 100644 (file)
@@ -43,7 +43,3 @@ SRC_URI = "\
      file://CVE-2020-0551.patch \
 "
 S  = "${WORKDIR}/git"
-
-do_configure_prepend () {
-        rm -rf ${S}/gdb ${S}/libdecnumber ${S}/readline ${S}/sim
-}
index f6c20fc229c819e5d7b235d5e8dfe397406dd0aa..4119960c634d19db7047bbee8bebfdb056a592fd 100644 (file)
@@ -75,6 +75,11 @@ EXTRA_OECONF = "--program-prefix=${TARGET_PREFIX} \
                 --disable-werror \
                 --enable-deterministic-archives \
                 --enable-plugins \
+                --disable-gdb \
+                --disable-gdbserver \
+                --disable-libdecnumber \
+                --disable-readline \
+                --disable-sim \
                 ${LDGOLD} \
                 ${EXTRA_TARGETS} \
                 ${@bb.utils.contains('DISTRO_FEATURES', 'multiarch', '--enable-64-bit-bfd', '', d)}"
index bfc93468226de53b74d0dc4b1cc6b522c5a1207d..2e645e1ed885846cb13ddad1ecad4b5df6623b53 100644 (file)
@@ -18,6 +18,11 @@ EXTRA_OECONF_class-native = "--enable-targets=all \
                              --enable-64-bit-bfd \
                              --enable-install-libiberty \
                              --enable-install-libbfd \
+                             --disable-gdb \
+                             --disable-gdbserver \
+                             --disable-libdecnumber \
+                             --disable-readline \
+                             --disable-sim \
                              --disable-werror"
 
 # gcc9.0 end up mis-compiling libbfd.so with O2 which then crashes on target