]> code.ossystems Code Review - openembedded-core.git/commitdiff
Update for panel 2 and fix packaging bugs
authorRoss Burton <ross@openedhand.com>
Wed, 24 Jan 2007 14:30:56 +0000 (14:30 +0000)
committerRoss Burton <ross@openedhand.com>
Wed, 24 Jan 2007 14:30:56 +0000 (14:30 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@1201 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/matchbox-sato/matchbox-sato/etc/matchbox/session
meta/packages/matchbox-sato/matchbox-sato_0.1.bb

index 46419d8206d1f63b0f92d1433530e7f5aa4b3277..e4b4a3b191fd4f16612afc00dcd03fd7d04752a2 100755 (executable)
@@ -20,19 +20,15 @@ case `module_id` in
 esac
 
 ## All this should be done by themeing/xsettings.. ## 
-matchbox-desktop --icon-size 48 \
-                 --icon-padding 64 \
+matchbox-desktop --icon-size 64 \
+                 --icon-padding 128 \
                  --font sans-16:bold \
                  --titlefont sans-16:bold &
 
-mb-applet-startup-monitor &                 
+mb-applet-startup-monitor &                 
 
-#matchbox-panel --orientation east \
-#               --padding 4 \
-#               --no-menu \
-#               --no-session \
-#               --default-apps mb-applet-home,mb-applet-clock,mb-applet-battery &
+matchbox-panel --titlebar --start-applets showdesktop --end-applets clock &
 
-exec matchbox-window-manager -use_cursor $SHOWCURSOR $@
+exec matchbox-window-manager -theme Sato -use_desktop_mode decorated -use_cursor $SHOWCURSOR $@
 
 
index 49ece1f68c30a354402f20ee7644c323251e1406..06721d7e649d1d5ccc182022d726b7788c0d8e0e 100644 (file)
@@ -1,8 +1,8 @@
 DESCRIPTION = "Custom MB session files for poky"
 LICENSE = "GPL"
 SECTION = "x11"
-RDEPENDS = "matchbox matchbox-applet-startup-monitor gtk-sato-engine matchbox-theme-sato"
-PR = "r2"
+RDEPENDS = "matchbox matchbox-applet-startup-monitor gtk-sato-engine matchbox-theme-sato gtk-theme-sato matchbox-panel-2"
+PR = "r4"
 
 SRC_URI = "file://etc"
 S = ${WORKDIR}
@@ -14,7 +14,7 @@ do_install() {
        chmod -R 755 ${D}/etc
 }
 
-pkg_postinst_matchbox-poky () {
+pkg_postinst_matchbox-sato () {
 #!/bin/sh -e
 if [ "x$D" != "x" ]; then
     exit 1