]> code.ossystems Code Review - openembedded-core.git/commitdiff
systemd-serialgetty: skip package when not using systemd
authorRoss Burton <ross.burton@intel.com>
Mon, 21 Jan 2013 18:09:20 +0000 (18:09 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 21 Jan 2013 18:56:02 +0000 (18:56 +0000)
As this package RDEPENDS on systemd it wants to build systemd, but if systemd
isn't a DISTRO_FEATURE then that package is skipped so world builds fail.  Solve
this by skipping this package too.

Signed-off-by: Ross Burton <ross.burton@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-core/systemd/systemd-serialgetty.bb

index 3e2a0e36f589a1575b0123a2ccb0f54df07e4f60..96cbf31470233774643a604416df956e4186497a 100644 (file)
@@ -40,3 +40,9 @@ RDEPENDS_${PN} = "systemd"
 # This is a machine specific file
 FILES_${PN} = "${systemd_unitdir}/system/serial-getty@.service ${sysconfdir}"
 PACKAGE_ARCH = "${MACHINE_ARCH}"
+
+# As this package is tied to systemd, only build it when we're also building systemd.
+python () {
+    if not oe.utils.contains ('DISTRO_FEATURES', 'systemd', True, False, d):
+        raise bb.parse.SkipPackage("'systemd' not in DISTRO_FEATURES")
+}