]> code.ossystems Code Review - openembedded-core.git/commitdiff
bind: separate B and S
authorRobert Yang <liezhi.yang@windriver.com>
Tue, 12 May 2015 02:13:53 +0000 (19:13 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 14 May 2015 10:41:12 +0000 (11:41 +0100)
Fix B != S and separate them.

Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-connectivity/bind/bind_9.10.2.bb

index 539f63ea48d0b4b89cadf0ac9dc495346889bb85..1dc15a9da7396f04fe6cb91767c8ff8e043b1a20 100644 (file)
@@ -31,7 +31,9 @@ EXTRA_OECONF = " ${ENABLE_IPV6} --with-randomdev=/dev/random --disable-threads \
                  --sysconfdir=${sysconfdir}/bind \
                  --with-openssl=${STAGING_LIBDIR}/.. \
                "
-inherit autotools-brokensep update-rc.d systemd useradd pkgconfig
+inherit autotools update-rc.d systemd useradd pkgconfig
+
+PR = "r1"
 
 PACKAGECONFIG ?= ""
 PACKAGECONFIG[httpstats] = "--with-libxml2,--without-libxml2,libxml2"
@@ -58,7 +60,7 @@ do_install_prepend() {
        # clean host path in isc-config.sh before the hardlink created
        # by "make install":
        #   bind9-config -> isc-config.sh
-       sed -i -e "s,${STAGING_LIBDIR},${libdir}," ${S}/isc-config.sh
+       sed -i -e "s,${STAGING_LIBDIR},${libdir}," ${B}/isc-config.sh
 }
 
 do_install_append() {