]> code.ossystems Code Review - openembedded-core.git/commitdiff
mesa: remove python2 detection hack
authorRoss Burton <ross.burton@intel.com>
Thu, 8 Nov 2012 11:31:31 +0000 (11:31 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 12 Nov 2012 12:44:42 +0000 (12:44 +0000)
Our python-native is 2.7.3 which ships python2, and we've been patching it in to
earlier versions since September 2011.

Signed-off-by: Ross Burton <ross.burton@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-graphics/mesa/mesa-8.0.4.inc
meta/recipes-graphics/mesa/mesa-dri_8.0.4.bb
meta/recipes-graphics/mesa/mesa-dri_git.bb
meta/recipes-graphics/mesa/mesa-git.inc

index 9afb35dee62acf2a8ffe1741373602b5dec5bebc..c6307dc603780ab745ec940846d298f7572399c8 100644 (file)
@@ -13,8 +13,6 @@ SRC_URI[md5sum] = "d546f988adfdf986cff45b1efa2d8a46"
 SRC_URI[sha256sum] = "02ed19f4f5f6535dda03a9932a81438aa78ea723ebba1f39a3d49a70a4e1d07e"
 
 do_configure_prepend() {
-  #check for python not python2, because python-native does not stage python2 binary/link
-  sed -i 's/AC_CHECK_PROGS(\[PYTHON2\], \[python2 python\])/AC_CHECK_PROGS(\[PYTHON2\], \[python python\])/g' ${S}/configure.ac
   # We need builtin_compiler built for buildhost arch instead of target (is provided by mesa-dri-glsl-native)"
   sed -i "s#\./builtin_compiler#${STAGING_BINDIR_NATIVE}/glsl/builtin_compiler#g" ${S}/src/glsl/Makefile
 }
index bd62c98ce459f0cc17772e063a90f443a92fbf0c..fb356764bf6c64f80ebb49f6e62aefd59899b556 100644 (file)
@@ -1,4 +1,4 @@
 require mesa-common.inc
 require mesa-${PV}.inc
 require mesa-dri.inc
-PR = "${INC_PR}.1"
+PR = "${INC_PR}.2"
index 4b36f20beba6477b6693111c46625a15ed65d48e..de1aa14cc1c34789d17b332037c03fc80c86d9f2 100644 (file)
@@ -5,5 +5,4 @@ require mesa-dri.inc
 # this needs to be lower than -1 because all mesa-dri have -1 and git version has highest PV, but shouldn't be default
 DEFAULT_PREFERENCE = "-2"
 
-PR = "${INC_PR}.0"
-
+PR = "${INC_PR}.1"
index 7910eb654d0a37bccd90d3998898056abbd639c9..b907931b7bf2e0c3901ea04ff3652c955061bf25 100644 (file)
@@ -16,8 +16,6 @@ SRC_URI += "${@base_contains('DISTRO_FEATURES', 'x11', '', 'file://0004-gross-ha
 S = "${WORKDIR}/git"
 
 do_configure_prepend() {
-  #check for python not python2, because python-native does not stage python2 binary/link
-  sed -i 's/AC_CHECK_PROGS(\[PYTHON2\], \[python2 python\])/AC_CHECK_PROGS(\[PYTHON2\], \[python python\])/g' ${S}/configure.ac
   # We need builtin_compiler built for buildhost arch instead of target (is provided by mesa-dri-glsl-native)"
   sed -i "s#\./builtin_compiler#${STAGING_BINDIR_NATIVE}/glsl/builtin_compiler#g" ${S}/src/glsl/Makefile
 }