]> code.ossystems Code Review - openembedded-core.git/commitdiff
shadow-sysroot: Use SYSROOT_DIRS to add dirs to stage in sysroot
authorPeter Kjellerstedt <peter.kjellerstedt@axis.com>
Thu, 12 May 2016 08:37:53 +0000 (10:37 +0200)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 13 May 2016 12:40:49 +0000 (13:40 +0100)
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-extended/shadow/shadow-sysroot_4.2.1.bb

index 697569c47ec286e78ac4e16ee6958882d42cb1ad..ef014628f61e43598b50cc8ab5be048e55db2b16 100644 (file)
@@ -21,12 +21,10 @@ S = "${WORKDIR}"
 
 do_install() {
        install -d ${D}${sysconfdir}
-       install -p -m 755 ${S}/login.defs_shadow-sysroot ${D}${sysconfdir}/login.defs
+       install -p -m 644 ${S}/login.defs_shadow-sysroot ${D}${sysconfdir}/login.defs
 }
 
-sysroot_stage_all() {
-       sysroot_stage_dir ${D} ${SYSROOT_DESTDIR}
-}
+SYSROOT_DIRS += "${sysconfdir}"
 
 # don't create any packages
 # otherwise: dbus-dev depends on shadow-sysroot-dev which depends on shadow-sysroot