]> code.ossystems Code Review - openembedded-core.git/commitdiff
xkeyboard-config: Inherit gettext
authorAndrei Gherzan <andrei@gherzan.ro>
Wed, 26 Nov 2014 16:22:14 +0000 (08:22 -0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 26 Nov 2014 17:01:44 +0000 (17:01 +0000)
In a GPLv3-free build we have two different versions of gettext in sysroot due
to GPLv3 restrictions. In this case we need gettext-native too so we can have
the needed macros and avoid errors like:
"error: possibly undefined macro: AM_GNU_GETTEXT"

The needed dependency is added by gettext class which is prefered because it
takes care of NLS flags too.

(From OE-Core rev: 23d8a4d64e9ff126d6460a69e6d086b1c86e87a9)

Signed-off-by: Andrei Gherzan <andrei.gherzan@windriver.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Signed-off-by: Armin Kuster <akuster808@gmail.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-graphics/xorg-lib/xkeyboard-config_2.12.bb

index 61e38470c1c032eab9d7649e0262b64cccbd6e26..adac0eedd8eb6e813f17fe03504774e1b39273c4 100644 (file)
@@ -23,7 +23,7 @@ EXTRA_OECONF = "--with-xkb-rules-symlink=xorg --disable-runtime-deps"
 
 FILES_${PN} += "${datadir}/X11/xkb"
 
-inherit autotools pkgconfig
+inherit autotools pkgconfig gettext
 
 do_install_append () {
     install -d ${D}${datadir}/X11/xkb/compiled