]> code.ossystems Code Review - openembedded-core.git/commitdiff
bluez-utils: upgraded to 3.17 from OE
authorMarcin Juszkiewicz <hrw@openedhand.com>
Fri, 7 Sep 2007 09:03:29 +0000 (09:03 +0000)
committerMarcin Juszkiewicz <hrw@openedhand.com>
Fri, 7 Sep 2007 09:03:29 +0000 (09:03 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@2714 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/bluez/bluez-utils.inc
meta/packages/bluez/bluez-utils_3.17.bb [new file with mode: 0644]

index ff3916ea948b1a3c5ec6b584bc1323d886a38494..3f90768708178ee88cbf938ea203e5c40790ed19 100644 (file)
@@ -1,60 +1,48 @@
 DESCRIPTION = "Linux Bluetooth Stack Userland Utilities."
 SECTION = "console"
 PRIORITY = "optional"
-DEPENDS = "bluez-libs-${PV} pcmcia-cs"
-RPROVIDES_${PN} = "bluez-pan bluez-sdp bluez-utils"
+DEPENDS = "gstreamer gst-plugins-base bluez-libs-${PV} libusb dbus"
+PROVIDES = "bluez-utils-dbus"
+RPROVIDES_${PN} = "bluez-pan bluez-sdp bluez-utils-dbus"
+RREPLACES_${PN} = "bluez-utils-dbus"
+RCONFLICTS_${PN} = "bluez-utils-nodbus"
 LICENSE = "GPL"
 
 SRC_URI = "http://bluez.sourceforge.net/download/bluez-utils-${PV}.tar.gz \
-       file://base.patch;patch=1 \
-       file://blueboxes.patch;patch=1 \
-       file://no-user-include.patch;patch=1 \
-       file://hcid.conf \
-       file://bluetooth.default \
-       file://bluetooth.conf \
-       file://02dtl1_cs.sh"
+           file://hcid.conf "
 
 # Almost all serial CF cards w/ manfid 0x0000,0x0000 seem to use the bcs protocol
 # Let's default to that instead of 'any' until further notice...
-SRC_URI += " file://default-manfid-0x0-to-bcps.patch;patch=1"
+#SRC_URI += " file://default-manfid-0x0-to-bcps.patch;patch=1"
 
 S = "${WORKDIR}/bluez-utils-${PV}"
 
-# We don't depend on openobex, fuse, alsa or usb but we set paths into staging
-# otherwise /usr/lib and /usr/include make it onto command lines with unpredictable results
-# Ideally acinclude.m4 needs fixing
-EXTRA_OECONF = "--with-bluez-libs=${STAGING_LIBDIR} --with-bluez-includes=${STAGING_INCDIR} \
-                --enable-pcmcia --enable-initscripts --enable-bcm203x --enable-hid2hci \
-               --disable-obex --disable-alsa \
-               --with-openobex=${STAGING_DIR}/${HOST_SYS} --with-fuse=${STAGING_DIR}/${HOST_SYS} \
-               --with-alsa=${STAGING_DIR}/${HOST_SYS} --with-usb=${STAGING_DIR}/${HOST_SYS} \
-               --with-bluez=${STAGING_LIBDIR}/${HOST_SYS}"
-
 inherit autotools update-rc.d
 
 INITSCRIPT_NAME = "bluetooth"
 INITSCRIPT_PARAMS = "defaults 23 19"
 
-do_compile_prepend() {
-       find ${S} -name Makefile | xargs sed -i 's:/usr/include:${STAGING_INCDIR}:'
-}
-
 do_install_append() {
-       install -d ${D}${base_sbindir} ${D}${base_bindir}/ ${D}${sysconfdir}/apm/event.d/
+       install -d ${D}${base_sbindir} ${D}${base_bindir}/  ${D}${sysconfdir}/apm/event.d/
        mv ${D}${sbindir}/* ${D}${base_sbindir}/
        mv ${D}${bindir}/* ${D}${base_bindir}/
        rmdir ${D}${bindir} ${D}${sbindir}
        chmod u+s ${D}${base_sbindir}/hciattach ${D}${base_sbindir}/hciconfig
-       chmod 755 ${D}${sysconfdir}/pcmcia/bluetooth
        install -m 0644 ${WORKDIR}/hcid.conf ${D}${sysconfdir}/bluetooth/
-       install -m 0644 ${WORKDIR}/bluetooth.default ${D}${sysconfdir}/default/bluetooth
-       cat ${WORKDIR}/bluetooth.conf >> ${D}${sysconfdir}/pcmcia/bluetooth.conf
-       install -m 0755 ${WORKDIR}/02dtl1_cs.sh ${D}${sysconfdir}/apm/event.d/
+        install -m 0755 ${S}/daemon/.libs/passkey-agent ${D}${base_bindir}/
 }
 
-CONFFILES_${PN} = "${sysconfdir}/bluetooth/hcid.conf ${sysconfdir}/bluetooth/rfcomm.conf \
-       ${sysconfdir}/bluetooth/pin ${sysconfdir}/default/bluetooth"
+PACKAGES =+ "${PN}-alsa ${PN}-alsa-dev gst-plugin-bluez gst-plugin-bluez-dbg"
+
+FILES_${PN}-alsa = "${libdir}/alsa-lib/libasound*"
+FILES_${PN}-alsa-dev += " ${libdir}/alsa-lib/*.la "
+
+FILES_gst-plugin-bluez = "${libdir}/gstreamer*/libgstblue*.so"
+FILES_gst-plugin-bluez-dbg = "${libdir}/gstreamer*/.debug/libgstblue*.so"
 
-PACKAGES =+ "${PN}-ciptool ${PN}-bluepin"
-FILES_${PN}-ciptool = "/bin/ciptool"
-FILES_${PN}-bluepin = "/bin/bluepin"
+#
+# CUPS support
+#
+#PACKAGES =+ " bluez-cups-backend"
+#FILES_bluez-cups-backend = "${libdir}/cups/backend/bluetooth"
+#RDEPENDS_bluez-cups-backend = "cups"
diff --git a/meta/packages/bluez/bluez-utils_3.17.bb b/meta/packages/bluez/bluez-utils_3.17.bb
new file mode 100644 (file)
index 0000000..8fa75c3
--- /dev/null
@@ -0,0 +1,107 @@
+require bluez-utils.inc
+
+DEPENDS += "glib-2.0"
+PR = "r1"
+
+# ti patch doesn't apply, people using it should rediff it and send it upstream
+#SRC_URI += "file://hciattach-ti-bts.patch;patch=1 "
+
+EXTRA_OECONF = " \
+                 --enable-bccmd \
+                --enable-hid2hci \
+                 --enable-alsa \ 
+                --disable-cups \
+                --enable-glib \
+                --disable-sdpd \
+                --enable-network \
+                --enable-serial \
+                --enable-input \
+                --enable-audio \
+                --enable-echo \
+                 --enable-configfile \
+                --enable-initscripts \
+                --enable-test \
+               "
+
+# The config options are explained below:
+
+#  --enable-obex           enable OBEX support
+#  --enable-alsa           enable ALSA support, not needed for nokia770, nokia800 and fic-gtao1
+#  --enable-cups           install CUPS backend support
+#  --enable-bccmd          install BCCMD interface utility
+#  --enable-avctrl         install Audio/Video control utility
+#  --enable-hid2hci        install HID mode switching utility
+#  --enable-dfutool        install DFU firmware upgrade utility
+
+#  --enable-glib           For systems that use and install GLib anyway
+#  --disable-sdpd          The sdpd is obsolete and should no longer be used. This of course requires that hcid will be started with -s to enable the SDP server
+
+#Following services can be enabled so far:
+#      --enable-network
+#      --enable-serial
+#      --enable-input
+#      --enable-audio
+#      --enable-echo
+
+#There is no need to modify any init script. They will be started
+#automatically or on demand. Only /etc/bluetooth/*.service files should
+#be patched to change name or the autostart value.
+#      --enable-configfile
+#      --enable-initscripts
+
+#For even smaller -doc packages
+#      --disable-manpages
+#      --disable-pcmciarules
+
+#I haven't seen any embedded device with HID proxy support. So simply
+#disable it:
+#      --disable-hid2hci
+
+
+PACKAGES =+ "${PN}-compat"
+
+CONFFILES_${PN} = " \
+                   ${sysconfdir}/bluetooth/hcid.conf \
+                   ${sysconfdir}/default/bluetooth \
+                  "
+
+CONFFILES_${PN}-compat = " \
+                          ${sysconfdir}/bluetooth/rfcomm.conf \
+                        "
+
+FILES_${PN} = " \
+               ${base_sbindir}/hcid \
+               ${libdir}/bluetooth \
+               ${sysconfdir}/init.d/bluetooth \
+               ${sysconfdir}/bluetooth/*.service \
+               ${sysconfdir}/bluetooth/hcid.conf \
+               ${sysconfdir}/default \
+               ${sysconfdir}/dbus-1 \
+              ${base_sbindir}/hciattach \
+              "
+
+FILES_${PN}-dbg += " \
+                   ${libdir}/bluetooth/.debug \
+                  ${libdir}/cups/backend/.debug \
+                  ${libdir}/alsa-lib/.debug \
+                 "
+
+FILES_${PN}-compat = " \
+                    ${base_bindir}/sdptool \
+                    ${base_bindir}/dund \
+                   ${base_bindir}/rctest \
+                   ${base_bindir}/ciptool \
+                   ${base_bindir}/l2test \
+                   ${base_bindir}/rfcomm \
+                   ${base_bindir}/hcitool \
+                   ${base_bindir}/pand \
+                   ${base_bindir}/hidd \
+                   ${base_bindir}/l2ping \
+                   ${base_sbindir}/hciconfig \
+                    ${base_sbindir}/bccmd \
+                   ${base_sbindir}/hciemu \
+                   ${base_sbindir}/hid2hci \
+                   ${base_bindir}/passkey-agent \
+                   ${sysconfdir}/bluetooth/rfcomm.conf \
+                  "
+