]> code.ossystems Code Review - openembedded-core.git/commitdiff
perf: mkdir ${B} -> mkdir -p ${B}
authorRobert Yang <liezhi.yang@windriver.com>
Fri, 18 Sep 2015 12:15:19 +0000 (14:15 +0200)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Sat, 19 Sep 2015 10:10:51 +0000 (11:10 +0100)
${B} is the default cwd of tasks, so there might be race issues such as:
| mkdir: cannot create directory `/path/to/work/qemux86-poky-linux/perf/1.0-r9/perf-1.0/': File exists
[snip]
NOTE: recipe perf-1.0-r9: task do_configure: Failed

Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-kernel/perf/perf.bb

index 1f1f552ca4e4334e41bbdf0fb81c3f1d691cf310..cf759183085782d475f120a32cf590986d25ff98 100644 (file)
@@ -119,7 +119,7 @@ do_install() {
 do_configure_prepend () {
     # Fix for rebuilding
     rm -rf ${B}/
-    mkdir ${B}/
+    mkdir -p ${B}/
 
     #kernels before 3.1 do not support WERROR env variable
     sed -i 's,-Werror ,,' ${S}/tools/perf/Makefile