]> code.ossystems Code Review - openembedded-core.git/commitdiff
autoconf: update runtime dependencies
authorKang Kai <kai.kang@windriver.com>
Wed, 24 Oct 2012 06:09:52 +0000 (14:09 +0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 24 Oct 2012 11:47:29 +0000 (12:47 +0100)
Update autoconf runtime dependencies on perl and perl modules. And
remove RDEPENDS for nativesdk because the nativesdk-autoconf has same
dependencies with autoconf.

Then fixes autoreconf runs failed both on target and toolchain.

Bump up PR.

[Yocto 3100]

Signed-off-by: Kang Kai <kai.kang@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/autoconf/autoconf.inc
meta/recipes-devtools/autoconf/autoconf_2.69.bb

index 315e7737482865f3c03bffe8c20f659abe29f01c..ff375cd69e6af6e05ef0e41e335460ecda472899 100644 (file)
@@ -8,9 +8,24 @@ SECTION = "devel"
 DEPENDS += "m4-native"
 DEPENDS_virtclass-native = "m4-native gnu-config-native"
 DEPENDS_virtclass-nativesdk = "nativesdk-m4 nativesdk-gnu-config"
-RDEPENDS_${PN} = "m4 gnu-config"
+RDEPENDS_${PN} = "m4 gnu-config \
+                 perl \
+                 perl-module-carp \
+                 perl-module-constant \
+                 perl-module-errno \
+                 perl-module-exporter \
+                 perl-module-file \
+                 perl-module-file-basename \
+                 perl-module-file-compare \
+                 perl-module-file-copy \
+                 perl-module-file-glob \
+                 perl-module-file-path \
+                 perl-module-file-stat \
+                 perl-module-getopt-long \
+                 perl-module-io-file \
+                 perl-module-posix \
+                "
 RDEPENDS_${PN}_virtclass-native = "m4-native gnu-config-native"
-RDEPENDS_${PN}_virtclass-nativesdk = "nativesdk-m4 nativesdk-gnu-config"
 
 SRC_URI = "${GNU_MIRROR}/autoconf/autoconf-${PV}.tar.gz \
           file://program_prefix.patch"
index 2c4c675645b3671499173b52791c9ac28b4c0b75..a4afd33bcf58966942c9e003be470d1a6669be37 100644 (file)
@@ -1,6 +1,6 @@
 require autoconf.inc
 
-PR = "r9"
+PR = "r10"
 
 PARALLEL_MAKE = ""