]> code.ossystems Code Review - openembedded-core.git/commitdiff
self-hosted-image: Create a VMDK image with correct SYSLINUX_* settings
authorSaul Wold <sgw@linux.intel.com>
Thu, 1 Mar 2012 07:46:22 +0000 (23:46 -0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 1 Mar 2012 15:40:02 +0000 (15:40 +0000)
Signed-off-by: Saul Wold <sgw@linux.intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-core/images/self-hosted-image.bb

index a0a759209143aa7a02b8dfbcc6a27e4b72419c98..d56c2cb37f63b897ef181e2ff7b1b428feba7a77 100644 (file)
@@ -1,11 +1,23 @@
 IMAGE_INSTALL = "task-core-boot task-core-apps-console task-core-ssh-openssh task-self-hosted"
 
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58 \
+                    file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
+
+PR = "r5"
+
 CORE_IMAGE_EXTRA_INSTALL = "\
     task-self-hosted \
     "
 
 IMAGE_FEATURES += "x11-mini package-management"
 
-inherit core-image
+# Ensure there's enough space to do a core-image-minimal build, with rm_work enabled
+IMAGE_ROOTFS_EXTRA_SPACE = "2621440"
 
-PR = "r2"
+# Do a quiet boot with limited console messages
+APPEND += "quiet"
+
+IMAGE_FSTYPES = "vmdk"
+
+inherit core-image