]> code.ossystems Code Review - openembedded-core.git/commitdiff
selftest/devtool: Update after make PROVIDER changes
authorRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 28 Mar 2016 14:50:54 +0000 (15:50 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 28 Mar 2016 14:54:50 +0000 (15:54 +0100)
Now that make/remake needs a PREFERRED_PROVIDER, we need to set this
correctly during tests.

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/lib/oeqa/selftest/devtool.py

index fe9f7f77a47bc8feb1934bc84f1769065019a1a9..32025bed32a8311b21223b29836a1337009b64db 100644 (file)
@@ -929,6 +929,7 @@ class DevtoolTests(DevtoolBase):
         tempdir = tempfile.mkdtemp(prefix='devtoolqa')
         # Try devtool extract
         self.track_for_cleanup(tempdir)
+        self.append_config('PREFERRED_PROVIDER_virtual/make = "remake"')
         result = runCmd('devtool extract remake %s' % tempdir)
         self.assertTrue(os.path.exists(os.path.join(tempdir, 'Makefile.am')), 'Extracted source could not be found')
         # devtool extract shouldn't create the workspace