]> code.ossystems Code Review - openembedded-core.git/commitdiff
libxml2: control ipv6 support based on DISTRO_FEATURES
authorJackie Huang <jackie.huang@windriver.com>
Mon, 22 Aug 2016 09:05:59 +0000 (17:05 +0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Sat, 3 Sep 2016 22:45:44 +0000 (23:45 +0100)
Add PACKAGECONFIG for ipv6 and control it based
on DISTRO_FEATURES.

Signed-off-by: Jackie Huang <jackie.huang@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-core/libxml/libxml2_2.9.4.bb

index e2febf0c60b792e207e546bc947bb4f5ed62062d..265d2b73a9797683c3ee81e6d2518343516fa327 100644 (file)
@@ -38,8 +38,11 @@ RDEPENDS_${PN}-ptest_append_libc-glibc = " glibc-gconv-ebcdic-us glibc-gconv-ibm
 
 export PYTHON_SITE_PACKAGES="${PYTHON_SITEPACKAGES_DIR}"
 
-PACKAGECONFIG ??= "python"
+PACKAGECONFIG ??= "python \
+    ${@bb.utils.contains('DISTRO_FEATURES', 'ipv6', 'ipv6', '', d)} \
+"
 PACKAGECONFIG[python] = "--with-python=${PYTHON},--without-python,python"
+PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6,"
 
 # WARNING: zlib is require for RPM use
 EXTRA_OECONF = "--without-debug --without-legacy --with-catalog --without-docbook --with-c14n --without-lzma --with-fexceptions"