]> code.ossystems Code Review - openembedded-core.git/commitdiff
weston: fix build without wayland in distro_features
authorRobert Yang <liezhi.yang@windriver.com>
Sat, 22 Feb 2014 07:18:34 +0000 (15:18 +0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 28 Feb 2014 13:52:44 +0000 (13:52 +0000)
There was a configure error when build weston without wayland in
distro_features:

configure: error: Package requirements (egl >= 7.10 glesv2 wayland-client wayland-egl) were not met:

No package 'wayland-egl' found

[YOCTO #5867]

Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
meta/recipes-graphics/wayland/weston_1.4.0.bb

index 5c389a0e0410ce1faba9b9a9d4bc36bb6ceb7948..e0c354d59fe00876b5e03b438e5f0b5dde175471 100644 (file)
@@ -39,7 +39,7 @@ PACKAGECONFIG ??= "${@base_contains('DISTRO_FEATURES', 'wayland', 'kms fbdev way
 # Weston on KMS
 PACKAGECONFIG[kms] = "--enable-drm-compositor,--disable-drm-compositor,drm udev virtual/mesa mtdev"
 # Weston on Wayland (nested Weston)
-PACKAGECONFIG[wayland] = "--enable-wayland-compositor,--disable-wayland-compositor,virtual/mesa"
+PACKAGECONFIG[wayland] = "--enable-wayland-compositor,--disable-egl --disable-wayland-compositor,virtual/mesa"
 # Weston on X11
 PACKAGECONFIG[x11] = "--enable-x11-compositor,--disable-x11-compositor,virtual/libx11 libxcb libxcb libxcursor cairo"
 # Headless Weston