]> code.ossystems Code Review - openembedded-core.git/commitdiff
openssl_1.0: avoid running make twice for target do_compile()
authorAndre McCurdy <armccurdy@gmail.com>
Tue, 24 Jul 2018 02:38:52 +0000 (19:38 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 29 Aug 2018 14:22:24 +0000 (15:22 +0100)
Currently target builds call make twice as part of do_compile(). It
appears to be an accidental side effect of needing to only pass
CC_INFO on the make command line for target builds, since CC_INFO is
only referenced by the reproducible build patches.

(From OE-Core rev: 6c4942b5c771876ad0e62e56923f59cc71776157)

Signed-off-by: Andre McCurdy <armccurdy@gmail.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Signed-off-by: Armin Kuster <akuster808@gmail.com>
meta/recipes-connectivity/openssl/openssl_1.0.2o.bb

index 58627b0b3e6d68cccfa198558ee0f37000b518f5..9e5e7ec0f9d53701dbefa82baa425c8f426ff246 100644 (file)
@@ -210,16 +210,16 @@ do_configure () {
        perl ./Configure ${EXTRA_OECONF} ${PACKAGECONFIG_CONFARGS} shared --prefix=$useprefix --openssldir=${libdir}/ssl --libdir=$libdirleaf $target
 }
 
-do_compile_prepend_class-target () {
-       sed -i 's/\((OPENSSL=\)".*"/\1"openssl"/' Makefile
+do_compile () {
        oe_runmake depend
-       cc_sanitized=`echo "${CC} ${CFLAG}" | sed -e 's,--sysroot=${STAGING_DIR_TARGET},,g' -e 's|${DEBUG_PREFIX_MAP}||g'`
-       oe_runmake CC_INFO="$cc_sanitized"
+       oe_runmake
 }
 
-do_compile () {
+do_compile_class-target () {
+       sed -i 's/\((OPENSSL=\)".*"/\1"openssl"/' Makefile
        oe_runmake depend
-       oe_runmake
+       cc_sanitized=`echo "${CC} ${CFLAG}" | sed -e 's,--sysroot=${STAGING_DIR_TARGET},,g' -e 's|${DEBUG_PREFIX_MAP}||g'`
+       oe_runmake CC_INFO="$cc_sanitized"
 }
 
 do_compile_ptest () {