]> code.ossystems Code Review - openembedded-core.git/commitdiff
quilt: move empty quiltrc to native sysconfdir
authorSaul Wold <sgw@linux.intel.com>
Thu, 19 Apr 2012 22:11:01 +0000 (15:11 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 24 Apr 2012 14:51:35 +0000 (15:51 +0100)
patch.bbclass orignally pointed at /usr/bin/quiltrc for an empty
version to ensure that no user setting were picked up, change this
to /etc/quiltrc in the Native sysroot since we now have a native
sysconfdir.

Make sure that the quiltrc is actually installed in the Native
sysconfdir, not the target, so fix this after the recipe split.

Signed-off-by: Saul Wold <sgw@linux.intel.com>
meta/classes/patch.bbclass
meta/recipes-devtools/quilt/quilt-0.51.inc
meta/recipes-devtools/quilt/quilt-native.inc
meta/recipes-devtools/quilt/quilt-native_0.51.bb
meta/recipes-devtools/quilt/quilt_0.51.bb

index 31db9e372a08f05c0ca29a5e353c74335c58d541..3c4d99783389f2be300fba4cc4616330cc837c75 100644 (file)
@@ -1,7 +1,7 @@
 # Copyright (C) 2006  OpenedHand LTD
 
 # Point to an empty file so any user's custom settings don't break things
-QUILTRCFILE ?= "${STAGING_BINDIR_NATIVE}/quiltrc"
+QUILTRCFILE ?= "${STAGING_ETCDIR_NATIVE}/quiltrc"
 
 PATCHDEPENDENCY = "${PATCHTOOL}-native:do_populate_sysroot"
 
index e89013aab0f72e6feeb533d1d9da38f3e1a1b719..824e624a437da70736029ca22504473bf4433e90 100644 (file)
@@ -24,11 +24,6 @@ RDEPENDS_${PN} = "bash"
 # quilt ignores DESTDIR
 do_install () {
        oe_runmake 'BUILD_ROOT=${D}' install
-       if [ "${BUILD_ARCH}" == "${HOST_ARCH}" ]; then
-               # Dummy quiltrc file for patch.bbclass
-               install -d ${D}${bindir}/
-               touch ${D}${bindir}/quiltrc
-       fi
        # cleanup unpackaged files
        rm -rf ${D}/${datadir}/emacs
 }
index 7efea0213dec205fa46d23b8acfa948f98956eeb..9345d88273a57fbd11efa1fa99b58dc5aad67ce4 100644 (file)
@@ -11,3 +11,9 @@ EXTRA_OECONF = "--disable-nls"
 do_configure () {
        oe_runconf
 }
+
+do_install_append () {
+       # Dummy quiltrc file for patch.bbclass
+       install -d ${D}${sysconfdir}/
+       touch ${D}${sysconfdir}/quiltrc
+}
index b99b9b65d2766f52c05409db5c00c5c5eb1e2d5a..1494bf2eb4cc69ad9ed3a1721a1764dd37ccd41a 100644 (file)
@@ -1,4 +1,4 @@
 require quilt-${PV}.inc
 require quilt-native.inc
 
-PR = "r0"
+PR = "r1"
index bc62161761076910d1c672de82439bef809e2e56..6865cd8738a8e7b54c6b07b0113df8ad9e22d8d9 100644 (file)
@@ -4,4 +4,4 @@ RDEPENDS_${PN} += "patch diffstat bzip2 util-linux"
 SRC_URI += "file://aclocal.patch \
             file://gnu_patch_test_fix_target.patch \
            "
-PR = "r2"
+PR = "r3"