]> code.ossystems Code Review - openembedded-core.git/commitdiff
xorg-driver-common: remove AC_CHECK_FILE workaround
authorRoss Burton <ross.burton@intel.com>
Tue, 6 Nov 2012 12:32:35 +0000 (12:32 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 12 Nov 2012 12:42:37 +0000 (12:42 +0000)
The drivers don't generally use AC_CHECK_FILE anymore, so remove this
brute-force kludge. Any subsequent breakage can be worked-around in the recipe
and fixes submitted upstream.

Signed-off-by: Ross Burton <ross.burton@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-graphics/xorg-driver/xorg-driver-common.inc

index f9f25ffe954f4e42078c0087a1337b4d3ecc771c..d2c9a5f4532f31d4ca37a14821c313c7166432ed 100644 (file)
@@ -5,7 +5,7 @@ SECTION = "x11/drivers"
 LICENSE = "MIT-X"
 
 PE = "2"
-INC_PR = "r18"
+INC_PR = "r19"
 
 DEPENDS = "virtual/xserver xproto randrproto util-macros"
 
@@ -18,14 +18,6 @@ FILES_${PN}-dbg += " ${libdir}/xorg/modules/drivers/.debug"
 
 inherit autotools pkgconfig
 
-# AC_CHECK_FILE doesn't work when cross compiling, so we create a replacement
-# macro that simply assumes the test succeeds. 
-do_configure_prepend () {
-    echo 'AC_DEFUN(CC_AC_CHECK_FILE, $2)' > configure.ac.new
-    sed 's/AC_CHECK_FILE/CC_AC_CHECK_FILE/g' configure.ac >> configure.ac.new
-    mv configure.ac.new configure.ac
-}
-
 # FIXME: We don't want to include the libtool archives (*.la) from modules
 # directory, as they serve no useful purpose. Upstream should fix Makefile.am
 do_install_append() {