]> code.ossystems Code Review - openembedded-core.git/commitdiff
libical: Work around hardcoded paths in pkgconfig file
authorRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 4 Feb 2016 13:07:53 +0000 (13:07 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 4 Feb 2016 13:09:51 +0000 (13:09 +0000)
For now, work around the hardcoded path in the pkgconfig file.
Issue filed upstream as:

https://github.com/libical/libical/issues/227

This raises questions about whether some sanity tests are running.
Those issues will be addressed in a separate patch.

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-support/libical/libical_2.0.0.bb

index fdbe026761bd46f142ff57505d8f750ef8167066..1042e6fa3876ea092d0e3adfb1414b8834e513de 100644 (file)
@@ -18,3 +18,10 @@ UPSTREAM_CHECK_URI = "https://github.com/libical/libical/releases"
 inherit cmake
 
 FILES_${PN}-dev += "${libdir}/cmake/*"
+
+#
+# Turn specific library paths in the pkgconfig file into standard library entries
+#
+do_install_append () {
+       sed -i -e "s#${STAGING_LIBDIR}/lib\([a-z0-9]*\)\.so#-l\1#g" ${D}${libdir}/pkgconfig/libical.pc
+}