]> code.ossystems Code Review - openembedded-core.git/commitdiff
packagegroup-core-base-utils: Make it machine specific
authorRicardo Ribalda Delgado <ricardo@ribalda.com>
Thu, 25 Jul 2019 07:21:10 +0000 (09:21 +0200)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 26 Jul 2019 07:41:02 +0000 (08:41 +0100)
Recipe makes use of the variable MACHINE_FEATURES, which is machine
specific:

  ${@bb.utils.contains("MACHINE_FEATURES", "keyboard", "kbd", "", d)}

This patch avoids multiconfig errors such as:

ERROR: mc:qt5222:packagegroup-core-base-utils-1.0-r0 do_package_qa_setscene: Error executing a python function in exec_python_func() autogenerated:

The stack trace of python calls that resulted in this exception/failure was:
File: 'exec_python_func() autogenerated', lineno: 2, function: <module>
     0001:
 *** 0002:do_package_qa_setscene(d)
     0003:
File: '/workdir/repo/poky/meta/classes/insane.bbclass', lineno: 1026, function: do_package_qa_setscene
     1022:SSTATETASKS += "do_package_qa"
     1023:do_package_qa[sstate-inputdirs] = ""
     1024:do_package_qa[sstate-outputdirs] = ""
     1025:python do_package_qa_setscene () {
 *** 1026:    sstate_setscene(d)
     1027:}
     1028:addtask do_package_qa_setscene
     1029:
     1030:python do_qa_staging() {

Signed-off-by: Ricardo Ribalda Delgado <ricardo@ribalda.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-extended/packagegroups/packagegroup-core-base-utils.bb

index 611e0cafcc19d427ca0c2596c6546a41b7d08914..18e227144a56e9af146812c3d43c0780eb087c36 100644 (file)
@@ -5,6 +5,8 @@
 SUMMARY = "Full-featured set of base utils"
 DESCRIPTION = "Package group bringing in packages needed to provide much of the base utils type functionality found in busybox"
 
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
 inherit packagegroup
 
 VIRTUAL-RUNTIME_vim ?= "vim-tiny"