]> code.ossystems Code Review - openembedded-core.git/commitdiff
coreutils: fix for native and nativesdk
authorDengke Du <dengke.du@windriver.com>
Tue, 26 Apr 2016 05:59:19 +0000 (22:59 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 17 May 2016 13:42:17 +0000 (14:42 +0100)
The do_install_append is used for moving/renaming for ALTERNATIVE, but
it breaks native, for example there is no ln, but ln.coreutils, that
makes coreutils-native don't work. This patch fixes the problem.

Signed-off-by: Dengke Du <dengke.du@windriver.com>
Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-core/coreutils/coreutils_8.25.bb

index 419a693372c9bc817503ebfbc8fd35a38f5c9b67..b1aaf539fbe3f1e7dc02424a6e810f30c4c74ef2 100644 (file)
@@ -69,6 +69,15 @@ do_compile_prepend () {
        mkdir -p ${B}/src
 }
 
+do_install_class-native() {
+       autotools_do_install
+       # remove groups to fix conflict with shadow-native
+       rm -f ${D}${STAGING_BINDIR_NATIVE}/groups
+       # The return is a must since native doesn't need the
+       # do_install_append() in the below.
+       return
+}
+
 do_install_append() {
        for i in df mktemp base64; do mv ${D}${bindir}/$i ${D}${bindir}/$i.${BPN}; done
 
@@ -91,11 +100,6 @@ do_install_append() {
        cp -a ${D}${mandir}/man1/test.1 ${D}${mandir}/man1/lbracket.1.${BPN}
 }
 
-do_install_append_class-native(){
-       # remove groups to fix conflict with shadow-native
-       rm -f ${D}${STAGING_BINDIR_NATIVE}/groups
-}
-
 inherit update-alternatives
 
 ALTERNATIVE_PRIORITY = "100"