]> code.ossystems Code Review - openembedded-core.git/commitdiff
perl: Fix errors if configure is reattempted
authorRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 21 Jan 2013 10:53:01 +0000 (10:53 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 21 Jan 2013 18:55:19 +0000 (18:55 +0000)
If configure of perl is reattempted it currently fails as it tries to edit
files outside ${S}. Chaging from ${WORKDIR} to ${S} avoids this issue
and allows rebuilds to work.

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/perl/perl_5.14.2.bb

index f924ebd6d050b24b5afcf1916be9e85b1bf4a017..e875c1f57483116ad9c5d4e2461182b9271186c0 100644 (file)
@@ -168,7 +168,7 @@ do_configure() {
                        ;;
        esac
         # These are strewn all over the source tree
-        for foo in `grep -I --exclude="*.patch" --exclude="*.diff" --exclude="*.pod" --exclude="README*" -m1 "/usr/include/.*\.h" ${WORKDIR}/* -r -l` ${S}/utils/h2xs.PL ; do
+        for foo in `grep -I --exclude="*.patch" --exclude="*.diff" --exclude="*.pod" --exclude="README*" -m1 "/usr/include/.*\.h" ${S}/* -r -l` ${S}/utils/h2xs.PL ; do
             echo Fixing: $foo
             sed -e 's|\([ "^'\''I]\+\)/usr/include/|\1${STAGING_INCDIR}/|g' -i $foo
         done