]> code.ossystems Code Review - openembedded-core.git/commitdiff
kernel.bbclass: Give sanity check function an opt-out variable
authorCalifornia Sullivan <california.l.sullivan@intel.com>
Tue, 28 Feb 2017 01:02:43 +0000 (17:02 -0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Sat, 4 Mar 2017 10:42:34 +0000 (10:42 +0000)
Having no opt-out method and adding the task to linux-yocto.inc was
causing issues. For example, linux-yocto-dev would often fail because
it uses AUTOREV with no way to dynamically change the PV.

Add a variable to turn off the sanity check, allowing an easy opt out,
and set the opt-out variable in linux-yocto-dev, fixing the issue with
AUTOREV.

Signed-off-by: California Sullivan <california.l.sullivan@intel.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/classes/kernel.bbclass
meta/recipes-kernel/linux/linux-yocto-dev.bb

index 3cd59fd7491e93cd7598d71f30bd782da55549cd..1e0646a437d4e892f1afadc1cc415ec8bf0f4a76 100644 (file)
@@ -327,6 +327,10 @@ do_install[prefuncs] += "package_get_auto_pr"
 
 # Must be ran no earlier than after do_kernel_checkout or else Makefile won't be in ${S}/Makefile
 do_kernel_version_sanity_check() {
+       if [ "x${KERNEL_VERSION_SANITY_SKIP}" = "x1" ]; then
+               exit 0
+       fi
+
        # The Makefile determines the kernel version shown at runtime
        # Don't use KERNEL_VERSION because the headers it grabs the version from aren't generated until do_compile
        VERSION=$(grep "^VERSION =" ${S}/Makefile | sed s/.*=\ *//)
@@ -350,7 +354,7 @@ do_kernel_version_sanity_check() {
        reg="${reg}${EXTRAVERSION}"
 
        if [ -z `echo ${PV} | grep -E "${reg}"` ]; then
-               bbfatal "Package Version (${PV}) does not match of kernel being built (${vers}). Please update the PV variable to match the kernel source."
+               bbfatal "Package Version (${PV}) does not match of kernel being built (${vers}). Please update the PV variable to match the kernel source or set KERNEL_VERSION_SANITY_SKIP=\"1\" in your recipe."
        fi
        exit 0
 }
index b9487d6e695079971b99ad23b48a5bd723ac8c38..444ee4111ded58808507dee5e133b97cafa206ee 100644 (file)
@@ -44,3 +44,4 @@ KERNEL_FEATURES_append_qemux86=" cfg/sound.scc cfg/paravirt_kvm.scc"
 KERNEL_FEATURES_append_qemux86-64=" cfg/sound.scc"
 KERNEL_FEATURES_append = " ${@bb.utils.contains("TUNE_FEATURES", "mx32", " cfg/x32.scc", "" ,d)}"
 
+KERNEL_VERSION_SANITY_SKIP = "1"