]> code.ossystems Code Review - openembedded-core.git/commitdiff
boost/libxslt: Enable nativesdk to unbreak <bitbake universe>
authorLi Zhou <li.zhou@windriver.com>
Thu, 30 Apr 2015 09:34:23 +0000 (17:34 +0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Sun, 3 May 2015 10:39:46 +0000 (11:39 +0100)
When run <make universe.fetchall>, the make will be broken because
nativesdk-boost and nativesdk-libxslt don't exist.
nativesdk-boost is depended by nativesdk-curlpp.
nativesdk-libxslt is depended by nativesdk-python-lxml.
In condition that meta-openembedded is compiled in.

Add nativesdk building for boost and libxslt.

Signed-off-by: Li Zhou <li.zhou@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-support/boost/boost.inc
meta/recipes-support/libxslt/libxslt_1.1.28.bb

index 6b42133aed69c47b8a23ad7699a3a5ff85ce385a..7628e37d6fbe972b0850f5912a47968103c89f85 100644 (file)
@@ -181,4 +181,4 @@ do_install() {
 
 }
 
-BBCLASSEXTEND = "native"
+BBCLASSEXTEND = "native nativesdk"
index ded883e457caba46d13993c11af47516da009924..166bcd86e7ad79b77c9fa4ab4201ca8d174dfa95 100644 (file)
@@ -43,4 +43,4 @@ do_install_append_class-native () {
 FILES_${PN} += "${libdir}/libxslt-plugins"
 FILES_${PN}-dev += "${libdir}/xsltConf.sh"
 
-BBCLASSEXTEND = "native"
+BBCLASSEXTEND = "native nativesdk"